Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
odn
Level 7

Roku Express Updating

Today when I turned on the Roku Express, the "Let's Get Started" screen appeared. The remote would not respond in to any command except "arrow right". The Express then found my wifi network, I entered the password and clicked "connect". Wireless and internet connections were made and the "Update Available" screen appeared. I ran the update. When it was done, Roku logo came-on for 10-15 seconds and then I got dumped right back where I started -- at the "Let's Get Started" screen.

I've done this 6 or more times., rebooting the modem and the express a number of times as well as depressing the reset button 30+seconds.

No matter what I do I end up with "Let's Get Started".

2 days ago when I last used the express it worked fine. Nothing in my wifi network has changed. What's up?

0 Kudos
2 Replies
Highlighted
atc98092
Level 17

Re: Roku Express Updating

Strange. I'm wondering if you had a power surge.

Anyway, other users have had this happen on occasion, and one remedy was to use a different Internet source, such as a phone hotspot. No idea on earth why that works, but it has for a number of users. 

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Highlighted
Roku Employee
Roku Employee

Re: Roku Express Updating

@odn 

Thanks the inquiry.

We recommend rebooting both your wireless router and your Roku device. Alternately, as @atc98092 mentioned, I'd also recommend trying to connect your device to an alternate network or mobile hotspot. If you are able to connect without issue, this usually indicates an issue with your network or password. In that case, you might also try changing your network password (avoid using any special characters from your wireless network password) to see if that resolves the connection issue. 

Please keep us posted.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos