Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
iwin07
Level 7

Roku Express 3930X not connecting to Spectrum Router

My new Roku will not connect to a SAGEMON FAST 5280 router.  The Roku shows a good signal strength.  The Spectrum Cable technician confirmed that the router is transmitting on the 2.4G band.  According to the Spectrum technician, I cannot turn off the 802.11b mode (which I read is one possible fix option).  I have reset the router and Roku numerous times.  Please help.

0 Kudos
2 Replies
AvsGunnar
Level 10

Re: Roku Express 3930X not connecting to Spectrum Router

Are you able to login to your router's adminstration panel and confirm that the 2.4gz is set to protocols b/g/n, you have a channel set between 1 thru 11 (ch 6 preferably), not 12, 13, 14 or AUTO, and 20mhz bandwidth. You will most likely need to toggle the 20mhz setting first to manually assign a channel.

You may have to use the Spectrum app if you can't login to the admin panel directly. 

0 Kudos
StreamerUser
Level 16

Re: Roku Express 3930X not connecting to Spectrum Router

@iwin07 wrote:

My new Roku will not connect to a SAGEMON FAST 5280 router.  The Roku shows a good signal strength.  The Spectrum Cable technician confirmed that the router is transmitting on the 2.4G band.  According to the Spectrum technician, I cannot turn off the 802.11b mode (which I read is one possible fix option).  I have reset the router and Roku numerous times.  Please help.

The Spectrum RACV21S (aka Sagemon Fast 5280) by default has no legacy "B" support, ergo it cannot be disabled;  however you can configure the mode/channel/bandwidth/WMM/APSD.

https://192.168.1.1/0.2/gui/#/wifi/2.4GHz/priv/basic

https://192.168.1.1/0.2/gui/#/wifi/2.4GHz/priv/advanced

Make sure you change the default password for the administrative UI, as well as the default SSIDs/passwords for 2.4Ghz and 5Ghz (and make sure the SSIDs are separate).

Otherwise you shouldnt be having any issues connecting in general - try using your phone as a HotSpot (or another wireless network) for the initial setup/firmware update, and then your Spectrum WiFi after that.

0 Kudos