Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
DenverLion
Level 7

Roku (4200x) connects to router, but not the internet. Same w/phone's hotspot.

Suddenly tonight, when I turned on my TV, the Roku (4200x) wasn't connected.  I checked the connection and it was connected to my router, but then the internet was a red "x".  I checked my phone and laptop and they are both connected to the router and the internet, so I restarted my Roku.  After restart, it still won't connect to the internet.  And I tried connecting it to both router networks (2.4, 5.0) and even tried connecting to my phone's wifi hotspot.  In each case, the "router" was a green check and the "internet" was a red "X".

I know I have an older model, but when I went to bed this morning (I work overnights) it was all working just fine.

0 Kudos
1 Reply
makaiguy
Level 20

Re: Roku (4200x) connects to router, but not the internet. Same w/phone's hotspot.

I've run into this here several times.  This has always worked for me:

  • Restart your router (even if other devices have no problem finding and connecting). Sometimes that's all it takes, if not keep going.
  • Restart the Roku to clear its memory via Settings > System > System restart (for a Roku TV it's Settings > System > Power > System restart). Again sometimes that's all it takes, if not keep going.
  • Find and connect to your network via Settings> Network > Set up connection

If that doesn't fix it, try disconnecting the power to your Roku for a few seconds.  When it comes back up, see if you then can set up the network connection.

  • Roku Streaming Stick +, 3810X, Ser YH0059427035, wifi - Samsung UN55ES6100
  • Roku Streaming Stick, 3600X, Ser 5S56D8240827, wifi - JVC EM37T
  • TCL Roku TV 43S425/C107X, Ser X000001R60KV, wifi
0 Kudos