Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Grabsplatter
Level 8

ROKU stick no longer shows 'Wired Connection' when choosing how to connect

My ROKU Stick no longer gives me the option to connect to 'Wired Connection'...only shows 'Wireless'....Both ROKU's in our house are showing the same issue

0 Kudos
7 REPLIES 7\
DBDukes
Community Streaming Expert

Re: ROKU stick no longer shows 'Wired Connection' when choosing how to connect

@Grabsplatter 

The Roku Stick only connects wirelessly. So you're saying that the device that cannot use an Ethernet connection no longer lists it as an option? They finally fixed that?

Or am I missing something?

DBDukes
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
Note: I am not a Roku employee.
0 Kudos
makaiguy
Community Streaming Expert

Re: ROKU stick no longer shows 'Wired Connection' when choosing how to connect

If you truly have one of the Roku Streaming Stick/Stick+ products, it has no provisions for a wired internet connection and can connect via wireless only.  Roku sticks are characterized by having a male HDMI connector on the end that can plug directly into an HDMI port on the tv.

Streaming Stick phyiscal configurationStreaming Stick phyiscal configurationUnfortunately, some people lately have begun calling all Roku devices "sticks".  If it has a female HDMI jack instead of a male HDMI connector, then it is NOT a "stick".

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.
Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X | Streaming Stick 3600

If this post solves your problem please help others find this answer by clicking "Accept as Solution.". Please only do this if it ACTUALLY solves your problem.
0 Kudos
StreamerUser
Level 20

Re: ROKU stick no longer shows 'Wired Connection' when choosing how to connect

@makaiguy 

I think a lot of this recent referring to non-stick models as sticks has to do with the change in form factor over the last several years from a larger square box to a small rectangular box with overall dimensions not too dissimilar from the stick models, aside from thickness (and not just with Roku), especially at the low end of the price curve which is popular with first time streamers (and where competitors' devices are almost always sticks), such that "streaming stick" or "stick" refers to any streaming device to them.

0 Kudos
makaiguy
Community Streaming Expert

Re: ROKU stick no longer shows 'Wired Connection' when choosing how to connect

@StreamerUser- I agree.  That's why I included the picture.

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.
Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X | Streaming Stick 3600

If this post solves your problem please help others find this answer by clicking "Accept as Solution.". Please only do this if it ACTUALLY solves your problem.
0 Kudos
Grabsplatter
Level 8

Re: ROKU stick no longer shows 'Wired Connection' when choosing how to connect

Thanks for the quick response. I think I may not be explaining it correctly. I have had a Roku stick for almost 3 years and have a smart tv that it is attached to. I have always had the option in the 'settings' menu to connect either 'wireless' or 'wired'... However it no longer gives me the option on both the Stick and the regular Roku on another tv in the house...I have watched tutorials on connectivity issues but cannot diagnose why.  To be fair, my wireless connection is fine but I have always preferred the wired connection.

0 Kudos
makaiguy
Community Streaming Expert

Re: ROKU stick no longer shows 'Wired Connection' when choosing how to connect

@Grabsplatter-

Let's clear this up right now.   Settings > System > About will give you the model name and number.  What are they?

Neither of my two Streaming Sticks (3600 and 3810) show anything other than a wireless connection option under Settings > Network > Set up connection at the present time.  Both wired and wireless options are present on my TCL Roku TV, which does have an Ethernet jack.  I don't recall ever seeing a wired connection being offered on my Streaming Sticks, or maybe I just ignored it, if it was there, because it obviously didn't apply.  If it WAS there previously it only makes sense to remove it to prevent it from confusing people.  Might you just be mis-remembering and confusing it with options presented by your TV itself and/or some other connected device like a satellite receiver, DVD player, etc?.

Whether the Roku stick setup ever showed a wired connection option or not, if you really have a Roku Streaming Stick product, you have never had an actual wired internet connection to it because there is no physical way to connect an Ethernet cable to any of the Streaming Stick products.

 

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.
Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X | Streaming Stick 3600

If this post solves your problem please help others find this answer by clicking "Accept as Solution.". Please only do this if it ACTUALLY solves your problem.
Grabsplatter
Level 8

Re: ROKU stick no longer shows 'Wired Connection' when choosing how to connect

I thoroughly appreciate your help..You are certainly very familiar with the product.  I have a ROKU Streaming Stick + Model 3910X in the master bedroom, along with a ROKU Express Model 3830X in the living room. Both used to show both ways to connect via Wireless and Wired but now only show wireless.  To be fair I have not noticed a difference in quality, just wondering if there was some kind of updated software that may have removed it.. I run 100mbps wired and only 54 mbps wireless.. I just find it odd because in the setup instructions is does give the option for connecting either way.  Thanks for all of your help!

0 Kudos