Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
R12CRIDER
Level 7

New Streaming Stick + doesn't list my 5ghz wifi connection as an option

Jump to solution

We recently purchased a streaming stick plus, for use in a location that's perhaps 40 feet from our router.  (Spectrum/Sagemcom).  It finds the 2ghz connection fine, but we get a fair amount of buffering, so I wanted to try our 5ghz connection, which is more than 2x faster per speedtest.  However, it doesn't show up.  I saw something about channel selection as a possible fix, but don't really understand.  Right now the router's settings page shows set to 'auto' says 'currently using channel 36'.  would this be responsible for our problem?  If so, how should I correct it?  Thanks in advance.

0 Kudos
1 Solution

Accepted Solutions
StreamerUser
Community Streaming Expert

Re: New Streaming Stick + doesn't list my 5ghz wifi connection as an option

Jump to solution

Yes, that's best practice - make sure you manually configure the channel from 149-165, save the configuration, restart your modem/gateway, then restart your Roku (and other devices if need be).

StreamerUser
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.

View solution in original post

7 REPLIES 7\
StreamerUser
Community Streaming Expert

Re: New Streaming Stick + doesn't list my 5ghz wifi connection as an option

Jump to solution

You'll need to manually configure the 5Ghz channel selection via the modem/gateway configuration pages Web UI (usually at http:/192.168.1.1 with a username/password of admin/admin or whatever is specifically printed on a label somewhere).

Once there, find the WiFi settings section for 5Ghz, and manually configure the channel (try the 149 to 165 channel range), and make sure the 2.4Ghz and 5Ghz SSIDs are different (if they aren't make them so) and visible. Save everything, restart the modem/gateway, after its done, restart your Roku (and other wireless devices), see if the 5Ghz appears - if not, repeat with another channel...

 

 

StreamerUser
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
makaiguy
Community Streaming Expert

Re: New Streaming Stick + doesn't list my 5ghz wifi connection as an option

Jump to solution

When in your router setup, give the 5 GHz band a different net name (SSID) than that used by the 2.4 GHz band. This way the Roku will show them separately in the list and allow you to choose the one you want. When they have the same name it seems to normally choose 2.4, I think because it will usually show a stronger signal - 5 GHz carries more data but 2.4 GHz penetrates walls better.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
Note: I am not a Roku employee, just a user like you.

Roku Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X | Roku Streaming Stick 3600
0 Kudos
R12CRIDER
Level 7

Re: New Streaming Stick + doesn't list my 5ghz wifi connection as an option

Jump to solution

Mine are differentiated by a suffix (xxx-2g vs xxx-5g). Is that sufficient?  It’s enough for me to tell them apart on all my other devices 

0 Kudos
StreamerUser
Community Streaming Expert

Re: New Streaming Stick + doesn't list my 5ghz wifi connection as an option

Jump to solution

Yes, that's best practice - make sure you manually configure the channel from 149-165, save the configuration, restart your modem/gateway, then restart your Roku (and other devices if need be).

StreamerUser
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.

View solution in original post

R12CRIDER
Level 7

Re: New Streaming Stick + doesn't list my 5ghz wifi connection as an option

Jump to solution

Thanks for your help.  Making the change in the Sagemcom setup and resetting did the trick.  After that the Roku found and connected to my 5ghz side no problem, and seems to have less buffering.  I was concerned that the weaker 5ghz signal wouldn't reach the Roku, in which case the speed differential wouldn't help us any, but for now we seem to be good.

0 Kudos
makaiguy
Community Streaming Expert

Re: New Streaming Stick + doesn't list my 5ghz wifi connection as an option

Jump to solution
@R12CRIDER wrote:

Thanks for your help.  Making the change in the Sagemcom setup and resetting did the trick.  After that the Roku found and connected to my 5ghz side no problem, and seems to have less buffering.  I was concerned that the weaker 5ghz signal wouldn't reach the Roku, in which case the speed differential wouldn't help us any, but for now we seem to be good.

Rokus with dual-band wifi also support channels 36-48 in the 5 GHz band.  The lower band numbers within the 5 GHz band are somewhat less attenuated by walls, etc.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
Note: I am not a Roku employee, just a user like you.

Roku Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X | Roku Streaming Stick 3600
0 Kudos
bobjungun
Level 7

Re: New Streaming Stick + doesn't list my 5ghz wifi connection as an option

Jump to solution

What I did was go into the admin console for network, added the device mac address and it showed up for me ¯\_(ツ)_/¯

0 Kudos