Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Just moved and Roku isn't seeing my wifi network

I recently moved and switched wifi companies (from Comcast to Spectrum). I'm trying to connect my roku to my new wifi and although it's seeing every other wifi network in my building (including other Spectrum networks) mine is not showing up on the screen. I've reset my roku and my router multiples times but my roku is still not seeing the wifi network. How do I fix this?

0 Kudos
4 Replies
Highlighted
Level 18

Re: Just moved and Roku isn't seeing my wifi network

What model Roku?  Of current models, low end Express and Premiere models only support 2.4 GHz wifi band, not 5 GHz band.  If your router is a dual band that supports both 2.4 GHz and 5 GHz bands, make sure router is configured with 2.4 GHz band enabled.

  • Roku Streaming Stick +, 3810X, Ser YH0059427035, wifi - Samsung UN55ES6100
  • Roku Streaming Stick, 3600X, Ser 5S56D8240827, wifi - JVC EM37T
  • TCL Roku TV 43S425/C107X, Ser X000001R60KV, wifi
0 Kudos
Highlighted
Level 7

Re: Just moved and Roku isn't seeing my wifi network

It’s a roku express. I can see the 2.4 GHz band on my phone, computer, and other devices, but not on my roku

0 Kudos
Highlighted
Level 7

Re: Just moved and Roku isn't seeing my wifi network


@eh805 wrote:

It’s a roku express. I can see the 2.4 GHz band on my phone, computer, and other devices, but not on my roku


Actually I just checked, and when I first set the wifi router up I could see the 2.4 GHz band and now I can't on my other devices

0 Kudos
Highlighted
Level 19

Re: Just moved and Roku isn't seeing my wifi network

Go through your router's Wi-Fi settings and make sure "hide SSID" or something similar isn't enabled.

0 Kudos