Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Issue Connecting to Network

Hi,

I am trying to setup the Roku on my parent's network for them and I cannot for the life of me get it to connect to their wireless network (error 014).  I have tried restarting their router, APs, and the Roku and still no luck.  I have been able to get the Roku to connect to my phone via Personal Hotspot.  I also have multiple other devices connected to the network (laptop, phones, PCs)--so it is not a password issue.

They have a small business network in their house including a Linksys LRT214 router and multiple APs (Linksys LAPAC1750 AC1750 Dual Band APs).  I have tried messing around with the network settings but have not had any luck.  I am guess it may be something with the firewall or some other network setting that is blocking it but I am at a loss at this point.  Any thoughts or suggestions with this type of network setup or something similar?

0 Kudos
3 Replies
Highlighted
Level 17

Re: Issue Connecting to Network

I think their router doesn't like the + in the model name (hostname). See the last post here:

https://community.linksys.com/t5/Linksys-Small-Business/LRT214-problem-with-setup/td-p/1063304

Shame on Roku for not following the specification.  I don't know if there's a setting within the router to allow special characters, but you may be able to change the name at https://my.roku.com under linked devices.  You'll probably have to connect it to your hotspot to get the name to change on the device.  I'd go through the router settings first.

Note that this is all mostly speculation on my part.

Highlighted
Level 10

Re: Issue Connecting to Network

Can the Roku see the SSID? Does it ask for the password, but fails to connect after you type in the password? Also, ensure that the SSID is not being broadcast on a DFS channel. 

My ROKU Info:
Roku Premier+ (Wireless | Static IP) - HDMI (1080P)
Roku Premier+ (Wireless | Static IP) - HDMI (1080P)
Spectrum Internet (100 Mbps / 10 Mbps)
Netflix; Hulu Plus; Amazon Prime
0 Kudos
Highlighted
Level 7

Re: Issue Connecting to Network

Thank you so much @renojim !  The "+" in the name was the issue.  Once i renamed it, it was able to connect to the network. 

This definitely something Roku should call out in their troubleshooting documentation as I wouldn't be surprised if other had this issue.

0 Kudos