Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 8

Re: Internet connectivity bug in 9.3 update?

Your fix is useless because this is a firmware update issue and not a user issue. The reason I say this is because I have a wired connection to my Ultra and am experiencing the same issue as the wireless users. Loss of internet connectivity on a Roku device when all other devices on the same network stay connected. 

0 Kudos
Highlighted
Level 7

Re: Internet connectivity bug in 9.3 update?

I had my express drop connection Friday night and last night.  I just verified the connection to get it to go again, made no other changes.  My system updated to 9.3 Friday night, just before the problems started.  

Highlighted
Level 8

Re: Internet connectivity bug in 9.3 update?

2.4 ghz working, read the comments, your device shows good wifi but no internet. It seems from all complaints to not be a wifi issue though the firmware may be written in a way where good wifi may not be the case though shown ok

Highlighted
Level 10

Re: Internet connectivity bug in 9.3 update?

My Ultra is still on 9.2 and I would like to go on record and say that I have not had a dropped or poor connection in several years. I wish that I could decline the 9.3 update.

I have seen this kind of pattern several years ago, where Roku made an update that caused issues for many people and support treated it as though the problems were with the individual connections. It took many months before they released an update that fixed it.

I feel bad for the Roku reps on this board that know the problems are related to Roku software, but are bound to respond with generic useless advice relating to individual connections. It is a shame that the company takes this approach because Roku is the best of all streaming devices when it is functioning properly.

Highlighted
Level 8

Re: Internet connectivity bug in 9.3 update?

I got nothin’ to add except my Insignia Roku TV takes about 20+ attempts to connect ever since the software update. I feel your pain guys.

0 Kudos
Highlighted
Level 7

Re: Internet connectivity bug in 9.3 update?

I am having the same issues

Highlighted
Level 7

Re: Internet connectivity bug in 9.3 update?

Can not reconnect on 5GHz since 9.3 firmware upgrade. Only will connect on 2.4 GHz. Just finished  watching a movie on 5GHz when I updated the firmware and now no more 5GHz connections.

Level 8

Re: Internet connectivity bug in 9.3 update?

Official explanation does specify that only 2.4GHz will work with express and premier. My problem with that is 1) Previous to the update the unit[s] were working perfectly on my 5GHz connection, so they obviously are capable of doing so. 2) While the ROKU[s] may work perfectly fine on the 2.4GHz band, other items on my home network definitely benefit from the 5GHz. This forces me to either live with the ROKU[s] {and their attached TV's} being isolated from the home network or upgrading the premiers in order to get a benefit that ROKU disabled intentionally thru a [mandatory] firmware update. Legal, yes. Ethical. less so. Best service practice, definitely NOT!!!

I can only echo others when I say that ROKU is probably the premier PRODUCT on the market, but their support: not so much.

Highlighted
Level 7

Re: Internet connectivity bug in 9.3 update?

I wish I could manual have prevented the update to the 9.3.0.  

Highlighted
Level 8

Re: Internet connectivity bug in 9.3 update?

I'm having the same issue.  Roku always gets excellent Wi-Fi signal and download speed, but will not connect to the Internet. I've had my ISP send a tech to check out all their equipment and all works as intended, but still Roku will not connect. I've re-set to factory parameters, re-started, unplugged, etc., etc., but still no internet. This after working perfectly for six years. Might the ROKU itself be faulty?