Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Daisyh1990
Level 8

I'm getting error message 014.30 and my roku device is not wanting to connect to my internet I have

Jump to solution

I'm getting error message 014.30 and my roku device is not wanting to connect to my internet I have tried to restart my roku device as well as my router several times and it is not fixing the issue. I have spoke to my internet provider and there is no issues on there end I'm not having issues with connecting my cell phone to wifi I don't know what else to do

2 Solutions

Accepted Solutions
AvsGunnar
Community Streaming Expert

Re: I'm getting error message 014.30 and my roku device is not wanting to connect to my internet I h

Jump to solution

@Daisyh1990 

Since you have the Arris TG1682 router, you may not be able adjust the settings I recommended above as these may be being managed automatically by Xfinity, but let's give it a shot.

First, you have to login to your router admin...

Make sure your laptop/computer is on the network connected to the wifi we are changing.

[1] Go to your web browser and type in 10.0.0.1 in the address bar.

This should bring up an Xfinity Gateway Screen (Xfi Interface) prompting for a Username and Password.   

[2] Username = admin    Password = password

This should then bring then up your main GUI interface.

[3] On the left hand side, select Advanced 

This should bring up Wireless Settings for both 2.4ghz and 5ghz band.  We are currently concerned with the 2.4ghz band.  Options for WiFi Mode, Channel Selection, and Channel Mode should now be present.  **If these are greyed out, then this means that the router is being managed automatically by your ISP (Xfinity) and the end-ser cannot make changes to this router.  In this case, you will have to call Xfinity again and have them make the changes to the router from their end to the settings recommended above.

Post back if you have gotten to this stage and what you have discovered.

 

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941

View solution in original post

AvsGunnar
Community Streaming Expert

Re: I'm getting error message 014.30 and my roku device is not wanting to connect to my internet I h

Jump to solution

Seems like the changes required was located under Gateway...Connection...Wifi  and not Advanced Settings, but resolution to issue was changing the Mode/Protocol under 2.4Ghz band from g/n to b/g/n as reflected in previous postings re: Xfinity managed and provided routers.  Good thing is @Daisyh1990 was able to make the changes from the Arris TG1682G router itself.

Xfinity2.png

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941

View solution in original post

12 REPLIES 12\
Daisyh1990
Level 8

Re: I'm getting error message 014.30 and my roku device is not wanting to connect to my internet I h

Jump to solution

I tried to call xfinity to ask about the possible change they made and the guy had no.clue what I was talking about please someone help my inis not the issue as the signal strength comes out as strong!

0 Kudos
AvsGunnar
Community Streaming Expert

Re: I'm getting error message 014.30 and my roku device is not wanting to connect to my internet I h

Jump to solution

@Daisyh1990 

If you have the Roku Express 3930/3931, then you will need to address your 2.4Ghz settings within the router.

Login to your router admin, and look for Wireless Settings.  Verify or change to the following for your 2.4 Ghz band...

[1]  2.4 radio is broadcasting On/Enabled

[2] Mode/Protocol is set to b/g/n

[3] Wireless Channel is set between 1 and 11, not Auto (you may try changing between 1 , 6, and 11 and note performance changes)

[4] Bandwidth/Channel Width is set to 20mhz

Restart your router (after pressing "Save changes")  and Roku after making above changes.  If this does not resolve issue, re-enter the router and look for "Wireless Security" and temporarily disable/remove your network/SSID password for the 2.4ghz band.  If you can connect without password, then change the password avoiding special characters and try again.

An additional test is to see if you can connect using a mobile hotspot.  If you can connect to a mobile hotspot 2.4ghz band, then usually indicative of a working Roku device and reinforces the need to configure the network router as specified above.

Post back with any updates or if you need more help.  Include actual Roku model number and your Router model number.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos
Daisyh1990
Level 8

Re: I'm getting error message 014.30 and my roku device is not wanting to connect to my internet I h

Jump to solution

@AvsGunnar wrote:

@Daisyh1990 

If you have the Roku Express 3930/3931, then you will need to address your 2.4Ghz settings within the router.

Login to your router admin, and look for Wireless Settings.  Verify or change to the following for your 2.4 Ghz band...

[1]  2.4 radio is broadcasting On/Enabled

[2] Mode/Protocol is set to b/g/n

[3] Wireless Channel is set between 1 and 11, not Auto (you may try changing between 1 , 6, and 11 and note performance changes)

[4] Bandwidth/Channel Width is set to 20mhz

Restart your router (after pressing "Save changes")  and Roku after making above changes.  If this does not resolve issue, re-enter the router and look for "Wireless Security" and temporarily disable/remove your network/SSID password for the 2.4ghz band.  If you can connect without password, then change the password avoiding special characters and try again.

An additional test is to see if you can connect using a mobile hotspot.  If you can connect to a mobile hotspot 2.4ghz band, then usually indicative of a working Roku device and reinforces the need to configure the network router as specified above.

Post back with any updates or if you need more help.  Include actual Roku model number and your Router model number.


I'm soooooooo lost after reading your response I'm so sorry I'm hoping you can walk me through jt step by step? I sent a private message I'm sooo sorry thank you for the help

0 Kudos
AvsGunnar
Community Streaming Expert

Re: I'm getting error message 014.30 and my roku device is not wanting to connect to my internet I h

Jump to solution

@Daisyh1990 

No worries, can be confusing.  Look at the bottom of your router and post back with your router model number and I will post a walkthrough for you to follow to make these changes.  From the PM image, can see that Roku is not being provided an IP address yet (0.0.0.0).

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos
Daisyh1990
Level 8

Re: I'm getting error message 014.30 and my roku device is not wanting to connect to my internet I h

Jump to solution

Okay I just sent it thank you so much for the help I haven't been able to use my device since yesterday and have no cable lol I'm hoping I can even understand the step by step instructions whould it be easier just to get a new roku?

0 Kudos
AvsGunnar
Community Streaming Expert

Re: I'm getting error message 014.30 and my roku device is not wanting to connect to my internet I h

Jump to solution

@Daisyh1990 

Since you have the Arris TG1682 router, you may not be able adjust the settings I recommended above as these may be being managed automatically by Xfinity, but let's give it a shot.

First, you have to login to your router admin...

Make sure your laptop/computer is on the network connected to the wifi we are changing.

[1] Go to your web browser and type in 10.0.0.1 in the address bar.

This should bring up an Xfinity Gateway Screen (Xfi Interface) prompting for a Username and Password.   

[2] Username = admin    Password = password

This should then bring then up your main GUI interface.

[3] On the left hand side, select Advanced 

This should bring up Wireless Settings for both 2.4ghz and 5ghz band.  We are currently concerned with the 2.4ghz band.  Options for WiFi Mode, Channel Selection, and Channel Mode should now be present.  **If these are greyed out, then this means that the router is being managed automatically by your ISP (Xfinity) and the end-ser cannot make changes to this router.  In this case, you will have to call Xfinity again and have them make the changes to the router from their end to the settings recommended above.

Post back if you have gotten to this stage and what you have discovered.

 

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941

View solution in original post

AvsGunnar
Community Streaming Expert

Re: I'm getting error message 014.30 and my roku device is not wanting to connect to my internet I h

Jump to solution

Seems like the changes required was located under Gateway...Connection...Wifi  and not Advanced Settings, but resolution to issue was changing the Mode/Protocol under 2.4Ghz band from g/n to b/g/n as reflected in previous postings re: Xfinity managed and provided routers.  Good thing is @Daisyh1990 was able to make the changes from the Arris TG1682G router itself.

Xfinity2.png

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941

View solution in original post

rmb1
Level 7

Re: I'm getting error message 014.30 and my roku device is not wanting to connect to my internet I h

Jump to solution

i am getting the same error message on both roku devices premier yh0078459837 and express yg0024737680. i have cox gateway router model tg1682g

i have rebooted everything countless times and have tried the fixes here. changing the channels on the 2.4 wifi, and the wifi mode to bgn. nothing in working. 

0 Kudos
RokuIrene-S
Roku Employee
Roku Employee

Re: I'm getting error message 014.30 and my roku device is not wanting to connect to my internet I h

Jump to solution

Hi @rmb1

Thanks for the post.

If you see one of the following error codes on your screen, take the recommended action to troubleshoot your network connection. Here is a link that can resolve the issue you are running with How to connect your Roku device to the internet using Wi-Fi or Ethernet.


All the best,
Irene

0 Kudos