Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Kdaniels24
Level 7

Express won't connect to network

Hello,

I’m having the same issue. I have tried several times setting up my second Roku Express+ streamer and I keep getting the message that it won’t connect to my network. However, my first Roku streamer (express+) and all of my other devices like my cell phone and laptop are connected with no problem. The device is closer to the router and I’ve restarted my router 3 times. My older Roku device works on both my TVs, but this new one isn’t and this is a replacement device, brand new. What’s the issue?

0 Kudos
2 Replies
RokuDanny-R
Roku Employee
Roku Employee

Re: Express won't connect to network

@Kdaniels24 

Thanks for the post.

I would recommend checking out our Support page for troubleshooting issues here: What should I do if I cannot connect to my home network or the internet?

Please answer the following questions so we can get a better understanding of what you are seeing:

- Have you ensured your router is broadcasting a 2.4GHz Wi-Fi network for the device to connect to? The Roku Express/Premiere is only compatible with wireless b/g/n networks on the 2.4 GHz spectrum. 
- Have you tried changing the wireless broadcast channel on the router to see if this will allow your device to connect? 
- Have you tried moving the device closer to your router to see if you can get connected? 
- How long have you been experiencing this problem?

If those things still aren't helping, feel free to send me a PM with your Roku account email address and the serial number of your Roku from Settings>System>About along with the answers to the above questions and I'll be able to assist you further from there.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Kdaniels24
Level 7

Re: Express won't connect to network

Hi Danny,

I’ve done all the steps you provided and it’s still not working. How do I PM you?

keAnna

0 Kudos