Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

“Error in the HTTP response...”

We recently switched from Optimum internet to Verizon Fios. We’re not having any problems on our phones, laptops, and desktops (several roommates is the same WiFi) but our TCL Roku TV keeps saying, “error in the http response. This could mean that malformed http headers or an http error code was returned” when we try to access Netflix, Disney +, amazon prime, etc. The roku tv acknowledges the internet connection and we can search online and watch YouTube but the apps aren’t even loading images of shows. 
We’ve reset factory settings, deleted and re-downloaded the apps, signed in and out, unplugged everything - nothing seems to work. 
Does anyone have any thoughts? 

0 Kudos
18 Replies
Highlighted
Level 7

Re: “Error in the HTTP response...”

...also, we used one of our iphone hotspots and were able to access everything fine, so it’s something between the roku and the modem, but Verizon is claiming the issue isn’t on their end.  

0 Kudos
Highlighted
Level 8

Re: “Error in the HTTP response...”

i get this message as well when using disney plus. theyve exhausted all opportunities to fix this and believe the issue is with roku

0 Kudos
Highlighted
Level 7

Re: “Error in the HTTP response...”

I am having the same issue with disney and prime. Like you said,  both work when accessing through phone hotspot.  Did you find a solution? 

0 Kudos
Highlighted
Level 8

Re: “Error in the HTTP response...”

not yet. i emailed roku but doubt i'll get a response anytime soon

Highlighted
Level 7

Re: “Error in the HTTP response...”

I reset my Orbi router, which was a pain, but that did the trick. Good luck!

0 Kudos
Highlighted
Level 7

Re: “Error in the HTTP response...”

I have the same problem and resetting my Orbi hasn't fixed it. Is this problem only with Orbing users?

0 Kudos
Highlighted
Level 7

Re: “Error in the HTTP response...”

I do think it's an Orbi problem, or it was for me.  Resetting the system, including satellites fixed it.

0 Kudos
Highlighted
Level 8

Re: “Error in the HTTP response...”

Resetting the orbi didn't work for me Smiley Sad

This is kind of ridiculous

0 Kudos
Highlighted
Level 10

Re: “Error in the HTTP response...”

@rob410 is it working for you using a hotspot also, just not your Orbi? 

0 Kudos