Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
NelsonDrake
Level 7

Error 14.30 / double flashing light

I'm posting this because nothing has fixed my problem yet, even though there are many posts about the same problem.

While using my Roku Express, my cablemodem got reset by Comcast. (not at all unusual) but that seems to have thrown the Roku for a loop. Here's what I've done so far:

On the Roku:
1. Tried to manually connect using the same SSID / PW.
2. Reset Network Settings
3. Factory Reset (I'm now stuck here)

On the cablemodem:
1. Changed the SSID 3 times
2. Changed the PW 3 times going from a normal complex password to simple all lowercase
3. Disabled ALL security
4. Restored security using what I had before: WPAWPA2-PSK (TKIP/AES)
5. Changed security to WPA2-PSK (AES)
5. Enabled SSID broadcast (I never broadcast my SSID)
6. Did a hard and soft reset of the cable modem itself
7. Did a soft reset of the WiFi module in the cable modem

All I get is a long flash and 2 short flashes on the Roku and error 014.30

Nothing changed, meaning no devices were moved (physically). My cable modem simply reset and now the Roku is lost in the wilderness. It has worked fine for 3 months and has seen similar resets before without a problem.

WiFi works. 2 phones, 1 tablet & 1 laptop connect fine.

Any ideas?

0 Kudos