Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
JackN777
Level 9

Connection issue WiFi Roku Express +

Roku Express + (3910x)

Has worked fine for months, all of a sudden, it says signal strength poor, and insists that I find another network to use.

AC1200 (Netgear) router... Not a darn thing has changed at all except the Roku for some reason.

Everything, and I mean everything other than the Roku works fine and connects, including the laptop I am typing this post with.

Is this some kind of issue with an recent update?

I'm about at my wits end with these Roku devices.

- Roku Express+ 3910X
- Roku Express+ 3910RW
- Roku Express+ 3710X
Tags (1)
0 Kudos
2 Replies
makaiguy
Level 20

Re: WiFi Connection issues Roku Express +

I've never received an explanation of what causes the loss of network connectivity, but so far this has always worked for me to recover from it:

  • Restart your router (even if other devices have no problem finding and connecting). Sometimes that's all it takes, if not keep going.
  • Restart the Roku to clear its memory via Settings > System > System restart (for a Roku TV it's Settings > System > Power > System restart). Again sometimes that's all it takes, if not keep going.
  • Find and connect to your network via Settings> Network > Set up connection

If that doesn't fix it, try disconnecting the power to your Roku for a few seconds.  When it comes back up, see if you then can set up the network connection.

  • Roku Streaming Stick +, 3810X, Ser YH0059427035, wifi - Samsung UN55ES6100
  • Roku Streaming Stick, 3600X, Ser 5S56D8240827, wifi - JVC EM37T
  • TCL Roku TV 43S425/C107X, Ser X000001R60KV, wifi
0 Kudos
JackN777
Level 9

Re: WiFi Connection issues Roku Express +

Appreciate the reply but...

Been there, done that...

Going to try a few things with the Router I saw others trying for this problem since the latest update. Like:

- "g" only for 2.4 ghz

- channel6 instead of auto

Roku needs to quit fixing stuff that ain't broken.

- Roku Express+ 3910X
- Roku Express+ 3910RW
- Roku Express+ 3710X
0 Kudos