Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mihalyo
Level 7

Cannot connect to wifi

I have the same problem as those in this thread. 
I've already tried the factory reset and it didn't work. 
iPhone hotspot trick didn't work. 
Unable to test other potentially available networks (without paying) 
Now I cannot access any other screen until the wi-fi works. 
 
ROKU model
Express+
YG00E6377337
purchased 12/16/2019
This appears to be due to the recent fw v9.4 update but I cannot verify that now as I cannot access the screen. 
 
D-Link modem/router 
DSL-2640B
2.4 GHz
 
everything else on-site is able to connect to my wifi network (6 devices). 
I hope that ROKU comes up with a solution. 
Thanks
Jeff
 
0 Kudos
8 Replies
RokuDanny-R
Roku Employee
Roku Employee

Re: Cannot connect to wifi

@mihalyo 

Thanks for the information, but it doesn't appear that your Roku device is on the OS 9.4.

I would recommend checking out our Support page for troubleshooting issues here: What should I do if I cannot connect to my home network or the internet?

Please answer the following questions so we can get a better understanding of what you are seeing:
- Have you ensured your router is broadcasting a 2.4GHz Wi-Fi network for the device to connect to? The Roku Express/Premiere is only compatible with wireless b/g/n networks on the 2.4 GHz spectrum. 
- Have you tried changing the wireless broadcast channel on the router to see if this will allow your device to connect? 
- Have you tried moving the device closer to your router to see if you can get connected? 
- How long have you been experiencing this problem?

If those things still aren't helping, feel free to send me a PM with your Roku account email address and the serial number of your Roku from Settings>System>About along with the answers to the above questions and I'll be able to assist you further from there.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
mihalyo
Level 7

Re: Cannot connect to wifi

Thank you Danny for your reply.

To answer your questions:

I am not certain that my device completed the install of the 9.4 upgrade. Before I factory reset the unit I saw that there was a ping from the server on (or around) November 14th. I received an email that stated that I was upgraded as well. Still, it was unclear that the process was completed. It may have only been partial. 

I can confirm that my router is broadcasting at 2.4GHz. My device was working fine until the 14th/15th of the month. 

I have attempted to change channel(s), but so far my Roku device cannot connect to my router's wifi. It can see it in the list of available hotspots, but stalls at connecting. 

My device is 7 feet from my router and has clear line of site with no obstructions. 

My device stopped working around November 14th-15th. 

I have since tried to reconnect using my iPhone personal hotspot again today and this time it worked. I got as far as connecting my device to the service via my registered e-mail. However when I logged into roku.com to finish the set-up process, the servers were down with an alert stating that there is currently a "service interruption" and to try again later. 

I will of course try again alter. 

Unfortunately I cannot access Settings>System>About screens until I can get past the wifi set up, so I am unable to source the serial number. I would be happy to supply you with that info and my account e-mail once I have all the info and the problem persists. 

It looks like the company is attempting to fix whatever broke. I am assuming it was something in the OS9.4 upgrade process. Maybe OS 9.4.1 will fix the problem. Unlike many on this forum I can have a bit of patience with this. I was an early adaptor to Roku. I had an early referrals account and I am a fan of the platform. Hopefully some resolution will be forthcoming soon. I hate to see the company eat-it because this. 

Good luck working the problem. 

Again, thank you for your reply.

JM

 

0 Kudos
mihalyo
Level 7

Re: Cannot connect to wifi

Hello Danny,

I am following up with a detail related to my previous message on this topic. 

I have attempted to retry setting-up my Roku from the factory setting using my iPhone hotspot. This appears to want to work but each time I try (in the last few days since my past post) I am not receiving ANY device-confirmation e-mails from Roku with my registered e-mail address. However I am receiving messages at that address from the message-board/community on this thread. It appears that the something is broken in the relay between setting-up the device and the e-mail confirmation service. Last week I did land on a confirmation link page but was served an alert that said "please try again later". Now I am unable to get that far in the setup process.

Although I have poked around in the hidden screens, there appears to be no screen that produces the serial # for my specific device.  (You asked for this in a previous post). 

I am wondering if Roku will ultimately honor a low price solution to upgrade to a device that works. I had purchased my current device in Dec 2019. I noticed it was a product created in 2018. I upgraded to that product when Roku discontinued service to my older box due to interface improvements. Perhaps it is speculation on my part that a newer device will work. If the company were to offer a hardware replacement I would be interested.   

In the meantime I hope you all are working the problem as it increasingly appears that many are still experiencing similar issues. 

Thank you for your attention

JM

0 Kudos
Martinr96
Level 7

Re: Cannot connect to wifi

Hello, 

I’ve just had a similar issue, I updated to 9.4.0 around a month ago on the automatic update. 

gradually the WiFi signal on my Roku got worse to now when it won’t connect at all, despite all other devices showing strong WiFi signal. 

ive checked the secret menus and checked the WiFi secret menu, which shows no signal at all. I’ve done the factory reset etc, and that appears to have made it even worse. 

I saw a post about reverting to a previous software build but this is not available. 

I wondered whether you came to a solution about this? 
thanks 

0 Kudos
jmcohio1978
Level 8

Re: Cannot connect to wifi

Same problem here, been through every " suggested" fix and absolutely no difference. Can put my second roku in the same spot and it works fine. Simple troubleshoot.... the thing just plain wont pick up wifi anymore. 4 months old. Not currently giving a positive review of the Roku premiere to anyone, based on everything ive read and now experienced trying to troubleshoot it, wondering if there shouldnt be an auto industry sized recall on the things. Customers should not have to be technicians to make it operate.

Martinr96
Level 7

Re: Cannot connect to wifi

Absolutely agree, mines only a Roku express HD but even so I’d expect it to do the bare minimum and be able to stream something at least.

0 Kudos
jmcohio1978
Level 8

Re: Cannot connect to wifi

im fed up lmao

0 Kudos
RokuDanny-R
Roku Employee
Roku Employee

Re: Cannot connect to wifi

Hi everyone,

Thanks for the posts.

As stated previously in this thread, I would recommend checking out our Support page for troubleshooting issues here: What should I do if I cannot connect to my home network or the internet?

Please answer the following questions so we can get a better understanding of what you are seeing:

- Have you ensured your router is broadcasting a 2.4GHz Wi-Fi network for the device to connect to? The Roku Express/Premiere is only compatible with wireless b/g/n networks on the 2.4 GHz spectrum. 
- Have you tried changing the wireless broadcast channel on the router to see if this will allow your device to connect? 
- Have you tried moving the device closer to your router to see if you can get connected? 
- How long have you been experiencing this problem?

If those things still aren't helping, feel free to provide us with:

-Roku device model
-serial number
-device ID
-software OS/version
(these can all be found in Settings > System > About)

-along with the answers to the above questions and I'll be able to assist you further from there


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos