Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
bombloader
Level 7

Can't connect. Never prompts for password.

My Roku TV stopped connecting to the network. Won't prompt for password even after doing a network reset. Have had this issue once before, was resolved by creating an entirely new wifi network with SSID and password. Don't have a problem with anything else connecting, just the TV. Network reset appears to be not really resetting anything, or else it would be asking for the password again. The worthless Roku support washed their hands of it because I was able to connect to my phone's hotspot and told me to call my ISP because of "DNS caching."  I'm a network engineer so I know that's BS. Anybody run into this problem?

0 Kudos
9 Replies
makaiguy
Level 21

Re: Can't connect. Never prompts for password.

Here's what has worked for me to re-establish my net connection. I usually have to do this on my most used Roku, a Streaming Stick+, several times a month.

  • Restart your router (even if other devices have no problem finding and connecting). Sometimes that's all it takes, if not keep going.
  • Restart the Roku to clear its memory via Settings > System > System restart (for Roku TV it's Settings > System > Power > System restart). Again sometimes that's all it takes, if not keep going.
  • Find and connect to your network via Settings> Network > Set up connection

If that doesn't fix it, try disconnecting the power to your Roku for a few seconds.  When it comes back up, see if you then can set up the network connection.

  • Roku Streaming Stick +, 3810X, Ser YH0059427035, wifi - Samsung UN55ES6100
  • Roku Streaming Stick, 3600X, Ser 5S56D8240827, wifi - JVC EM37T
  • TCL Roku TV 43S425/C107X, Ser X000001R60KV, wifi
0 Kudos
bombloader
Level 7

Re: Can't connect. Never prompts for password.

Already restarted the TV multiple times. Did restart the router and tried the power off shutdown of the Roku TV. Still same thing, it's detecting the networks, but they don't show locks and won't prompt for a password. I still think that this is the type of issue that would be solved by clearing the existing networks out and that the "network reset" isn't actually doing that.

0 Kudos
bombloader
Level 7

Re: Can't connect. Never prompts for password.

Also, I'm not seeing the connection attempts to the Roku TV in router logs. I can verify that router is logging the wifi handshake for other devices as I'm seeing it in the logs. 

0 Kudos
AvsGunnar
Community Streaming Expert

Re: Can't connect. Never prompts for password.

@bombloader 

Is the RokuTV IP address showing under Settings...System...About on the same network IP of your router. (ie If your router gateway is 196.168.1.0 is your RokuTV 192.168.1.xx)  Pay particular attention to the subsets.

Verify this info since you stated you created additional networks to remedy this issue prior.  Additionally, make sure you have no MAC filtering enabled.  

Additionally, I would release the RokuTV from the router's DHCP server, reboot the router, and do the Connection Reset yet again from the Roku.  You can do this from an alternate debug menu as well but the Connection Reset should disassociate the access point and reset the driver during the automatic restart of the TV during this process.  Of course this will only truly work if another setting within the router is not prohibiting its release.

I am not against DNS as a potential culprit for connection issues, but more internet related than network related.  The DNS ordinally should only come into play after successfully connecting to network.  A typical LAN network really doesn't care about the internet in connecting its devices to the network.  However, wireless Roku devices need to see an active working internet connection before it will successfully connect a wireless Roku device to the network.  You can bypass this requirement using an ethernet connection (if available on the Roku device).

There are a few ways to narrow down issue.  I would again eliminate router's DHCP server and DNS (do a quick ping or change them).  Post back after trying the above and then explain in detail what you did and are currently experiencing.  What worked, what didn't, any change in status.  Also include your router model number and your network setup.

 

 

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.

0 Kudos
bombloader
Level 7

Re: Can't connect. Never prompts for password.

At this point, no I was able to determine which MACs belong to which devices and the TV isn't on there. So it appears to be no longer connecting at all. Good to know that it won't connect if doesn't detect internet, but given that it's not getting an IP I'm guessing that's a non issue. As to the network, the router is Cradlepoint E300 SOHO router with three different subnets configured and three different wireless SSIDs. Each subnet is mapped to a different SSID. The TVs were connect to the SSID mapped to the 192.168.75.0/24 subnet. Internet connection is a Centurylink fiber. The centurylink modem is still in the connection but it's running in bridge mode between the Cradlepoint WAN port and the media converter. Do you have any information on the debug mode for the TV?

0 Kudos
AvsGunnar
Community Streaming Expert

Re: Can't connect. Never prompts for password.

@bombloader 

Just to clarify... Part of the Roku "Check Connection" feature is to detect both a network and internet availability.  If both are successful, your router's DHCP server will then assign the Roku device a LAN IP address.  

If you are not seeing an assignment via MAC address or under listed devices of LAN IP at the router, then there is likely a conflict among DHCP server somewhere.  Although in Bridge Mode, verify that DHCP is disabled at the Century Link. (Some routers will do this automatically, most others have a seperate setting under DHCP settings.).  If you are using multiple subnets, sounds like both may be acting as routers.  If the Cradlepoint is the main router, this has to be the only one with DHCP enabled. (Assuming you have ethernet cable from Century Link router LAN port to Cradlepoint WAN port to troubleshoot, as I see this router has wireless WAN capability as well)

 You can run multiple subnets, but each router's gateways need to be different in this configuration so that the individual router's DHCP server is only addressing those connected devices on a particular and seperate network.

Are you able to run an ethernet cable to this RokuTV from the Cradlepoint Router to see if you can get a LAN IP address assigned to the RokuTV. (Should be provided a Wired Connection if available). 

The fact that you were able to connect to the hotspot indicates the wireless hardware of the RokuTV is likely operating properly and capable of making a connection.  If you can also get a Wired Lan IP to show at the RokuTV, then narrowing down to a router setting mismatch somewhere.

Post back after verifying the above and trying the ethernet connection if available to you.  Trying to get a baseline where we are at.

 

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.

0 Kudos
Annapolina12
Level 7

Re: Can't connect. Never prompts for password.

Thank you very much. That helped!! 😀

0 Kudos
bombloader
Level 7

Re: Can't connect. Never prompts for password.

I tried to logon to the centurylink, but setting transparent bridge cuts access to the admin. I'd have to reset it to default, check the settings., then set back to transparent bridge. Honestly, I don't think the centurylink DHCP settings are affecting it, the TV was worked with the centurylink set in NAT mode, and now doesn't work with it in either. I haven't been able to get an ethernet cable long enough to connect yet, but I'm fairly confident wired connection would work, as it's usually much more robust. Just to clarify, how does the Roku check for internet connectivity, just to make sure it hasn't been blocked somehow. Also, I'm a bit confused about how it "checks" before it gets a DHCP IP address. I did try creating a reservation in the Cradlepoint's DHCP server and that didn't work any better. 

0 Kudos
AvsGunnar
Community Streaming Expert

Re: Can't connect. Never prompts for password.

@bombloader 

I will try to answer in sections....

"I tried to logon to the centurylink, but setting transparent bridge cuts access to the admin."

If you use an ethernet cable between your laptop and the CenturyLink you should be access the admin, no matter the mode it is assigned, as long as you are using the correct login address. (default is 192.168.0.1; sticker on router for admin and passwd).  You can try unplugging Cradlepoint to eliminate conflict during the login.  If you have your wireless radios set to "disabled" in the bridge mode, then you will not be able to login using wifi, need to use ethernet, or more advanced telnet.  If you find that you can no longer login to your CenturyLink with above methods, then a factory reset of the router is in order.  Does you no good to continue troubleshooting if you cannot see or verify settings.

Honestly, I don't think the centurylink DHCP settings are affecting it, the TV was worked with the centurylink set in NAT mode, and now doesn't work with it in either. I haven't been able to get an ethernet cable long enough to connect yet, but I'm fairly confident wired connection would work, as it's usually much more robust.

Normally recommend leave NAT enabled.  Disabling NAT in a CenturyLink causes problems in that some settings are affected in a manner automatically that cannot be user changed/modified. Additionally, many disable NAT, but then you have to configure the WAN IP at the Cradlepoint, normally including PPoE creds.  Normally disabled if another router is not handling bridge mode properly.

Regarding the ethernet connection, yes, could be termed more robust.  But more importantly, it bypasses the wireless configurations and settings of the routers.  As long as the WAN is operating properly, the Roku device (or any wired device) should be able to connect to the LAN network and proceed to the internet.

"Also, I'm a bit confused about how it "checks" before it gets a DHCP IP address."

For most internet streaming, like Roku, ports 80 (http), and 443 (https) are utilized and "usually" all that is required.  I assume the Roku does a simple check/ping for response on one of these ports which would result positive internet connection/pass condition available. (however, I also think it also takes into account the response time/speed test since slow internet connection will also yield a negative internet connection/fail condition.)  As such you may find other devices working fine, but the Roku not working since it failed the internet connection test.

For the Roku devices, you have to successfully pass both the network and internet connection tests to successfully set up initially.  Once successful, the Roku gets a LAN IP address assigned by the DHCP server.  You can then lose internet, and still potentially use ethernet connected Roku LAN features (Roku Media Player) and other server side features. [some can, some cannot...depends on network setup].

"I did try creating a reservation in the Cradlepoint's DHCP server and that didn't work any better. "

This is not normally, if ever, successful.  You cannot manually assign an IP to the Roku device.  Once your router and Roku successfully communicate with each other and the DHCP server assigns an IP address, then you can certainly after that create a reservation with that number.  Usually unneccessary if network is operating properly.

------Honestly, I think the problem is the Cradlepoint router setup and your multiple network setup.  Something has gone askew.  Since you had to create to new network/subnet previously to resolve the problem before, indicates that the problem is still there but you somehow were able to steer around it. (Didn't really resolve the problem, but were able to get it working in a different configuration.).  

Personally, I would start over.  I would factory reset the CenturyLink.  I would then verify I could connect wirelessly to the CenturyLink.  Then you know you have a good known working condition.  Then proceed in baby steps from there.  Re-enable bridge mode.  If works...good to go.  If not, and I suspect it will not, then next step is to factory reset the Cradlepoint. I think you have a mismatch/corrupt setting somewhere in the WAN communication from the Cradlepoint back to the Century Link that the Roku is having a problem with.   Although it may be irritating not knowing specifically what the issue is, sometimes best to just start over and move on and chalk it up to network gremlins.  

If you need the extended wifi coverage, then leave the CenturyLink in bridge mode.  If you need multiple networks but not the extended wifi coverage, then set the Century Link to modem and router mode and Cradlepoint to Access Point and assign each a different/distinct LAN IP and then connect your managed devices to the desired network accordingly.  Leaving the ISP Centurylink to do the modem tasking should eliminate most of the headaches.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.

0 Kudos