Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
AvsGunnar
Community Streaming Expert

Re: Hisense TV not connecting to Wi-Fi

@anjpatel6219 

The user that posted immediately after you, @wdhaines  is also experiencing a problem with the G3100 currently.  Let me see if they (Verizon) maybe pushed a firmware update to this router recently that may be causing the problem, or if just coincidence.

The fact that you "should" be at least seeing a 2.4Ghz connection for your TV even if the 5Ghz connection is unavailable, and the Premiere operates only on the 2.4Ghz, is telling...  But again, could be unrelated and just a coincidence.  I will look into it a bit and post back later today. 

Additionally, similar to advice given to @wdhaines, see if you also can connect your RokuTV to a hotspot (if available) to test connection.  Try both the hotspot 2.4Ghz and 5Ghz band options.

Please update if something changes for you or you have additional info in the meantime. 

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos
anjpatel6219
Level 7

Re: Hisense TV not connecting to Wi-Fi

@AvsGunnar 

Thanks! I have been having this issue since I first got the tv which was 6-8 months ago. I kinda just gave up on getting help from either Hisense or Roku support. 

0 Kudos
RokuKariza-D
Roku Employee
Roku Employee

Re: BOTH Roku device no longer connect to Wifi - but everything else in the house will

Hey @cckamau

Thanks for bringing this to our attention.

Please note that your Roku Express (3910RW) is a single-band wireless device that is only compatible with wireless b/g/n networks on the 2.4 GHz spectrum. Ensure that your router is broadcasting a 2.4GHz Wi-Fi network for the device to connect to.

If still no dice, try configuring your router and use wireless channels 1, 6, or 11 which are the preferred channels in North America. Each time you change the wireless channel, you will likely need to apply/save changes before you are prompted to restart the router.

Let us know how it goes!

All the best,
Kariza

Kariza D.
Roku Forum Moderator
0 Kudos
AvsGunnar
Community Streaming Expert

Re: BOTH Roku device no longer connect to Wifi - but everything else in the house will

@anjpatel6219 

No firmware updates have been released for the G3100 recently but seems like many people with this router are continuing to have problems keeping their 2.4Ghz connected to this router, namely Roku devices and security cameras.  Those with security cameras are especially annoyed.  Verizon's support responses seems to be limited to switch to Compatibility Mode under your Wireless Settings or to try replacing the router. (Replacing the router apparently works for very short time and problems returns, so common conclusion among users is probably a firmware and/or hardware issue).  I would lean more to firmware.

I think you have a different problem than @wdhaines , so appears unrelated.  Although it appears that the G3100 may have some 2.4Ghz compatibility issues with the Roku (maybe) , I think in your case I would look more into the Mesh feature of this router. (a.k.a. Self Organizing Network or SON) as the reason for your disconnections/inability to reconnect.  This Mesh feature basically automatically assigns and switches devices between the two network bands (2.4Ghz and 5Ghz bands) of your network depending where it determines the best connection is. (Or alternatively, if you lose a connection on the 5Ghz band, tries to switch to usually more stable 2.4Ghz connection).

Although generally these mesh routers are designed to give you better wifi coverage throughout home, they can cause problems if not configured properly (or if above is true, a faulty 2.4Ghz band is not performing properly.  Basically if you get disconnected from 5Ghz, no where else left to go).

Anytime the router is using automatic settings, or you are letting a router automatically configure/manage  a network, you are basically using the router's discretion.  When it works properly, it is great...When it doesn't work properly, just one headache after another tracking down problem.

Because you have a RokuTV, it is capable of operating on either the 2.4 or 5Ghz bands. (dual band device).  I would disable the SON (mesh feature) of your G3100 and configure the individual bands.  It sounds more complicated than it is.  Once you login to router admin, you will see the settings to change.  I have also included link for the user manual of this router.

 Here are the instructions I posted for another user to disable the SON feature. (G3100 Disable SON - Premiere Troubleshooting).  Repeated here....

The steps below are going to create a seperate 2.4gz network and seperate 5gz network by disabling the router's SON feature(Self-Organizing Network) that is creating this automatic band steering.  This is going to give you much better control of your network and isolate problems to the network easier.  It will also probably speed up non-ethernet 5gz devices by making sure they stay on the 5gz band.

Under your Wi-fi...Advanced... (p.42)     https://i.imgur.com/rMVUtFV.png (reference)

2.4 gz...

1.  Broadcast> Enable (this will broadcast the 2.4gz network radio)

2. 802.11 Mode> Switch to Legacy (This should broadcast b/g/n)

5gz...

1. Broadcast>Enable

2. 802.11 Mode>Compatibility (This should enable a/n/ac/ax)  

Other Advanced Options...

1. MeshWi-Fi Enabled>Switch to OFF. (This should disable SON, the merged network)

2. Transmit Power> set both 2.4 and 5 to High (100%)

Basic Settings

Rename your 2.4gz and 5gz Network SSIDs here. (ie. something and something5G).  Can keep your passwords the same.  [You should now have 2 distinct seperate networks, a 2.4gz and 5gz that is manually assignable regarding devices.

You may have to fiddle with channels but try Auto first on the 2.4gz.  Then go back and manually assign a channel.

For 2.4 Ghz band, setting should be channel 1-11 (preferably 1, 6, or 11), using Mode/Protocol b,g,n and a channel width of 20Mhz.

For 5 Ghz band, settings should be channel 36-48 (low band) or 149-161 (high band), Mode/Protocol N/AC, and channel width of 20Mhz initially. (The width can be adjusted higher later after confirming working to achieve potentially higher speeds)

***Compability modes mentioned above are the G3100 default settings.  These can be changed after you verify proper operation in order to increase speed or eliminate older protocols you may not need that may slow down your network.  Additionally, Roku cannot use DFS channels (on 5ghz, these are 52-140 and can be excluded from scanning in the G3100 if channel selection is set to Auto) [page49] 

Verizon G3100   https://www.verizon.com/support/residential/internet/equipment/routers/fios-router

----------------

After performing the above, I think you will find a much better experience with the RokuTV.  Post back with any updates or if you have any questions or need more help. 

Click Image to Enlarge

anjpatel1a.png

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos
mcd11
Level 8

Re: Roku won't pick up wifi

Add me to the ever-growing list of people with Premier devices suddenly **bleep** the bed. Wifi is working and strong and at 2.4, router is not far away, device finds the 2.4 wifi and just won’t connect. From what I’ve read through pages and pages here, sounds like a software update is to blame. cool. Cause we can’t connect to download any software bug fix. 

The device worked last night. It’s only 4 months old. If Roku is just avoiding this issue, that’s deplorable and really poor business. Do you just want us to buy another device? Do better, Roku!! I picked you cause I didn’t want to give Amazon any more money. 

RokuKariza-D
Roku Employee
Roku Employee

Re: Roku won't pick up wifi

Hello @mcd11

Thanks for bringing this to our attention.

 Can you provide the following information for further investigation:

-Roku device model
-Serial number
-Device ID
-Software OS/version
(these can all be found in Settings System About)
-Tracker ID when this issue occurs (when you see this issue occur, press the Home button 5 times, followed by the Back button 5 times)
-Steps to reproduce the issue you are seeing

With more information, we will be able to assist you further.

All the best,
Kariza

Kariza D.
Roku Forum Moderator
0 Kudos
OwnerofDevices
Level 11

Re: Roku won't pick up wifi

If you have a Verizon FIOS g3100 router, you need to disable SON or self organizing network. You can disable SON from the My FIOS phone app or you can login to your Verizon account on the web and disable SON there also. I had to make the same change on my G3100 in order to fix this problem with my 3 Roku TVs. 

0 Kudos
Plj
Level 8

Re: Roku no longer detects any wifi networks (after firmware update?)

I had the same thing happen to me today, when my internet company Cox, internet service was down for two hours. I have to separate TVs, with two completely separate Roku Expresses and neither one will connect to my server. What gives??? I've tried everything:

Restarted Roku (many times)

Had my internet company reboot modern (4 times!)

Followed all the instructions on the ROKU site and the last thing I just did on just one of the TVs was the factory reset. DIDN'T WORK!!

Will I have to switch to another brand of streaming product, like Amazon Fire?

 

0 Kudos
renojim
Community Streaming Expert

Re: Roku no longer detects any wifi networks (after firmware update?)

@Plj, your post is confusing.  You have two Roku Expresses but you factory reset the TV?  I assume you mean you factory reset one of the Expresses connected to one of the TVs.

This thread is about Roku devices that detect no Wi-Fi networks.  Is that your issue or do your Roku devices detect your Wi-Fi network, but won't connect?

There's a difference between a modem and a router, although they are often built into the same device.  If you have a separate modem and router you need to reboot both of them.

If you have a phone with a hotspot you can enable, try connecting to that and then check for updates.  Make sure your hotspot is configured to use 2.4GHz and a channel from 1 to 11.

Finally, what's the model number(s) of your device(s) shown under Settings->System->About?

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
wdhaines
Level 7

Re: Hisense TV not connecting to Wi-Fi

I was finally able to test this Roku at another house, and it did show a single 2.4G network. However, at home it does not show any networks, including when I disabled SON. Perhaps the antenna is degraded?

0 Kudos