Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Re: 9.3 Update loses connection

Thanks for info. My older Premier kept dropping wireless wifi after update. Always was a bulletproof unit up til this point. Microsoft has been having issues with updates too. 

0 Kudos
Highlighted
Level 9

Re: 9.3 Update loses connection

This may help.  Yesterday my 2 Streaming Stick+ & my Roku TV all had issues connecting to the internet.  When I checked my connection speed Roku was reporting 0-6 Mbps.  I have 100 to the house and Netflix usually reports 80+ easily.  I tried rebooting all devices including my cable modem (Motorola Arris) & WiFi Router & WiFi extender which has always cleared any WiFi connection issue.  No dice.  My internet speed to my router was 100+ (because of channel bonding) so no issues there.  So what was the cause of my issue and maybe yours as well?  I needed to change my DNS settings on my router.  They've always been set to the default which has worked for ever - until yesterday.  Here is what I did:

Replace the internal DNS address with a public DNS address. What worked was using Google’s public DNS. So set DNS1 to 8.8.8.8 and DNS2 to 8.8.4.4

Once I made the changes and applied them all of my Rokus connected without any problem.  The issue was only with my Rokus as all other WiFi connected devices worked just fine.  Something to look into if you haven't already.

0 Kudos
Highlighted
Level 7

Re: 9.3 Update loses connection

Thanks for the info... been cussing at this update for awhile now and finally decided to look if anyone else was experiencing it. Mine would connect (WiFi or wired) n

but then drop and require a full restart in order to pick it back up. They need to test their firmware releases more thoroughly!

0 Kudos
Highlighted
Level 7

Re: 9.3 Update loses connection

I have a separate post here about this same issue. I figured it out as I went out a bought a brand new Ultra that came loaded with previous 9.2 build. Unit in issue had 9.3 build. I am hoping the "automatic" upgrade wont happen to my new unit, or they decided to "ban" this 9.3 until they fix the bug.

Other question is how you accessed this secret menu. Your sequence is not the standard sequence used to access the secret menu.

Standard is

Home button 5 times.
Press the Fast Forward button once.
Press Play.
Then Rewind.
Play one more time.
Fast Forward..

Yours is different

Re: 9.3 Update loses connection
Hit the Home Button x5...
FF Button x3...
RW Button x2,
scroll down to Update Software, if it's possible to revert back it will say something like update from 9.3 to 9.2, if you do not see 9.2 might not be able to revert back.

So yours has different sequences. Maybe this is just another secret screen sequence as I know there are several secret screen accesses. How did you find this one to get to the firmware?

 

Here is my Ultra from January 2020 that died after it updated to 9.3. I may try to see if I can revert to 9.2 and use somewhere else.

Home Theater Roku Ultra.jpg

0 Kudos
Highlighted
Level 9

Re: 9.3 Update loses connection

I read about this "Secret Screen" that allows access to the s/w update option on this forum.  I am still on 9.2.0 after rolling back on both of my Streaming Stick+s and it's working fine.  The secret screen you knew about is called the "Platform Secret Screen" and I also learned about that on this forum.  FYI you can also access that "Platform Secret Screen" by using this sequence as it's what I read about and use but thanks as pressing PLAY instead of the DOWN ARROW is much easier!

  • Press HOME button 5 times
  • Press FF button 1 time
  • Press DOWN ARROW button 1 time
  • Press REW button 1 time
  • Press DOWN ARROW button 1 time
  • Press FF button 1 time
0 Kudos