Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 9

Re: 9.3 Update loses connection

Just an update - yesterday afternoon both of my SS+ (3810x) updated to version 9.3.0 build 4172.  I didn't notice it until late at night when I went to run a check of my connection speed.  I noticed that YouTube TV was connecting at a slightly higher rate than usual especially on 720p channels as I was connecting at around 35-38000 Kbps, something I would only see on a 1080p channel.  Netflix connecting at 75-80.  I have not see any buffering, pixelation or any sound sync issues so far but it's only been 24 hrs.  I am hoping that this build is stable because when I checked vers 9.2.0 was no longer available to revert to.

I also noticed that the YouTube app now looks more like the YTTV app when it loads so it appears to be an updated version.

0 Kudos
Highlighted
Level 7

Re: 9.3 Update loses connection

I have a Roku TV. Received the 9.3.0 4175-20 update today. My wireless connection dropped constantly. I have an Access Point (mesh wireless) beside the TV so 100 percent strength. I have had no issues prior to this.

Reverted back to 9.2.0 build 4808-20. Fixed the Wi-Fi dropping issue. Hopefully it'll be fixed soon. It's frustrating when it's obviously a known issue but has not been fixed yet.

0 Kudos
Highlighted
Level 8

Re: 9.3 Update loses connection

Any update on this issue? It’s been over a month since this and my roku Streaming stick is out. I connected it to my iPhone’s hotspot. It works then but I don’t see any new update. It is still stuck on 4170 build 24. 

0 Kudos
Highlighted
Level 7

Re: 9.3 Update loses connection

I just looked, I am now at 9.3.0 build 4182. Did not realize the TV had updated, so it is obviously working now.

 

0 Kudos
Highlighted
Level 9

Re: 9.3 Update loses connection

Powerguru - I have Streaming Stick + and can only speak for my experience on that as I don't work for Roku.  I would search for discussions on your particular model to see what is the latest version you should have.  In general all I can advise you is to try to do a factory reset and let it start from there to get the latest update.  I had to do this with one of my sticks.  The other I had to force the latest update again to clear up some weird issues with my TVs display and since then I've been ok and only had to reboot my wifi router and extender once.  One thing I noticed, and this may just be particular to YouTube TV, is that YTTV took a day to normalize, i.e. my streaming was this highest connection speeds I've seen and very stable.

Anyway I hope this helps.  LMK...

0 Kudos
Highlighted
Level 9

Re: 9.3 Update loses connection

bsawler - good to hear you're working ok.  I have a Sharp Roku TV that also updated last week and it is functioning fine as well.

Highlighted
Level 7

Re: 9.3 Update loses connection

I have two 4670Xs, both on wired connections, and one of them constantly drops the connection. They are running build 4170-46. I've gone into the secret screen and forced the firmware to re-apply over itself twice.

If phone support was open I'd call... I'm about ready to try email support, but I'm not holding my breathe.

0 Kudos
Highlighted
Level 8

Re: 9.3 Update loses connection

 


@BoltsFan wrote:

Powerguru - I have Streaming Stick + and can only speak for my experience on that as I don't work for Roku.  I would search for discussions on your particular model to see what is the latest version you should have.  In general all I can advise you is to try to do a factory reset and let it start from there to get the latest update.  I had to do this with one of my sticks.  The other I had to force the latest update again to clear up some weird issues with my TVs display and since then I've been ok and only had to reboot my wifi router and extender once.  One thing I noticed, and this may just be particular to YouTube TV, is that YTTV took a day to normalize, i.e. my streaming was this highest connection speeds I've seen and very stable.

Anyway I hope this helps.  LMK...


 thank you for the reply. I have Roku 3600X stick  I have tried many things but it is not able to connect to my home WiFi anymore. I have restarted router and the satellite. Roku multiple times. I feel my best bet is right now to connect roku with my iPhone and check for the updates when I have time. 😀.

0 Kudos
Highlighted
Level 9

Re: 9.3 Update loses connection

Have you changed your routers DNS settings as I posted some info on that.  It helped me and others.  Worth a try if you haven't.

0 Kudos
Highlighted
Level 7

Re: 9.3 Update loses connection

Is there a fix coming for the issues that the 9.3 update has created? If so, when?  I'm ready to throw every Roku device I own out the window & go to ANY OTHER service but Roku....

0 Kudos