Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Re: 9.3 Update loses connection

Thanks for info. My older Premier kept dropping wireless wifi after update. Always was a bulletproof unit up til this point. Microsoft has been having issues with updates too. 

0 Kudos
Highlighted
Level 9

Re: 9.3 Update loses connection

This may help.  Yesterday my 2 Streaming Stick+ & my Roku TV all had issues connecting to the internet.  When I checked my connection speed Roku was reporting 0-6 Mbps.  I have 100 to the house and Netflix usually reports 80+ easily.  I tried rebooting all devices including my cable modem (Motorola Arris) & WiFi Router & WiFi extender which has always cleared any WiFi connection issue.  No dice.  My internet speed to my router was 100+ (because of channel bonding) so no issues there.  So what was the cause of my issue and maybe yours as well?  I needed to change my DNS settings on my router.  They've always been set to the default which has worked for ever - until yesterday.  Here is what I did:

Replace the internal DNS address with a public DNS address. What worked was using Google’s public DNS. So set DNS1 to 8.8.8.8 and DNS2 to 8.8.4.4

Once I made the changes and applied them all of my Rokus connected without any problem.  The issue was only with my Rokus as all other WiFi connected devices worked just fine.  Something to look into if you haven't already.

0 Kudos
Highlighted
Level 7

Re: 9.3 Update loses connection

Thanks for the info... been cussing at this update for awhile now and finally decided to look if anyone else was experiencing it. Mine would connect (WiFi or wired) n

but then drop and require a full restart in order to pick it back up. They need to test their firmware releases more thoroughly!

0 Kudos
Highlighted
Level 7

Re: 9.3 Update loses connection

I have a separate post here about this same issue. I figured it out as I went out a bought a brand new Ultra that came loaded with previous 9.2 build. Unit in issue had 9.3 build. I am hoping the "automatic" upgrade wont happen to my new unit, or they decided to "ban" this 9.3 until they fix the bug.

Other question is how you accessed this secret menu. Your sequence is not the standard sequence used to access the secret menu.

Standard is

Home button 5 times.
Press the Fast Forward button once.
Press Play.
Then Rewind.
Play one more time.
Fast Forward..

Yours is different

Re: 9.3 Update loses connection
Hit the Home Button x5...
FF Button x3...
RW Button x2,
scroll down to Update Software, if it's possible to revert back it will say something like update from 9.3 to 9.2, if you do not see 9.2 might not be able to revert back.

So yours has different sequences. Maybe this is just another secret screen sequence as I know there are several secret screen accesses. How did you find this one to get to the firmware?

 

Here is my Ultra from January 2020 that died after it updated to 9.3. I may try to see if I can revert to 9.2 and use somewhere else.

Home Theater Roku Ultra.jpg

0 Kudos
Highlighted
Level 9

Re: 9.3 Update loses connection

I read about this "Secret Screen" that allows access to the s/w update option on this forum.  I am still on 9.2.0 after rolling back on both of my Streaming Stick+s and it's working fine.  The secret screen you knew about is called the "Platform Secret Screen" and I also learned about that on this forum.  FYI you can also access that "Platform Secret Screen" by using this sequence as it's what I read about and use but thanks as pressing PLAY instead of the DOWN ARROW is much easier!

  • Press HOME button 5 times
  • Press FF button 1 time
  • Press DOWN ARROW button 1 time
  • Press REW button 1 time
  • Press DOWN ARROW button 1 time
  • Press FF button 1 time
Highlighted
Level 8

Re: 9.3 Update loses connection

My ultra just updated to 9.3 yesterday. Has same connection issues mentioned for wired and wireless now. Secret menu does not allow reversion to 9.2. So disappointing. Have had nothing but trouble since purchased concerning wired connection, now they added a feature that includes wireless problems. Thanks ROKU!!!

0 Kudos
Highlighted
Level 7

Re: 9.3 Update loses connection

Add me to the list. My Ultra 4670X updated on 5/30 and I've had this problem with my wired connection all week! I tried setting a static IP for the Roku on my router and it didn't help. I just accessed the secret menu and I don't have a rollback option, all I could do was re-apply 4.3.0... I tried it, we'll see what happens.

0 Kudos
Highlighted
Level 7

Re: 9.3 Update loses connection

I am curious when you say "Wired" connection. Do you have WiFi available to test as well? I had issues with wired and switched to WiFi and that fixed certain things.

However the issue for me of it shutting down is unknown. I have a new Ultra now for 3 weeks and it is working fine. However, the caveat is, it still has the 9.2 firmware. We will see when or if it does the 9.3 update automatically to see if this new Ultra starts having same issue. If so then it FOR sure is related to the 9.3 update. I cannot confirm where my other Roku was bad or not until my new one gets the 9.3

0 Kudos
Highlighted
Level 7

Re: 9.3 Update loses connection

This is an update to my previous post. I reverted my older Premiere to 9.2 because it was dumping WiFi all the time after 9.3 was applied.. Yesterday, the 9.3 update came thru again. This time I am having no problems with connection, so far. I have never used a wired connection, only wireless. My newish Express took the new update on the second try. Never got it on the first one that messed up my connection on the Premiere.  So far, no problems at all on the Express unit.               I am quite interested in the new Google dongle that will be coming out With a remote! If Roku continues to have update problems, I may have to make some changes.

0 Kudos
Highlighted
Level 7

Re: 9.3 Update loses connection

Update: so far, so good after re-applying 9.3.0 on top of itself. The connection has held up after a few hours of being idle.

re:wired vs wifi - I haven't used wifi in awhile on this Roku, but I have other devices on the same switch AND the connection and activity lights on the Roku ethernet port are actually lit up. The disconnect seems to be solely on the software side.

0 Kudos