Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Laurassanchez
Level 7

3920x showing low signal to WiFi after system update.

It just had a system update on 05/12/21 and now it shows low signal. I'm getting error 017. It has a direct line of sight to the router and is less than 10 ft away. I've tried rebooting Roku,the router, removed the network and added it again and I m having the same issue. Anything else that can be done or am I better off getting a replacement? 

0 Kudos
11 REPLIES 11\
AvsGunnar
Community Streaming Expert

Re: 3920x showing low signal to WiFi after system update.

The 017 as I understand it is a weak wireless signal being detected.  This could either be a defective/failed device, your network settings may need to be adjusted, or your router may have an issue.  You can try changing the wireless channel from your router's 2.4ghz Wireless Settings to a less crowded one.  Normally try 1, 6, or 11 to begin with.  Then lower your bandwidth to 20mhz in same Wireless Settings section. (All these changes made in admin login at your router).  

Generally, between making the settings changes and moving the Premiere around to get a better signal (physically turning the Premiere box) is probably realistic extent of correcting the 017 error.  Using a wi-fi analyzer (app downloaded to your mobile device) you can test the strength of your network signal and then compare that to what your Premiere is indicating.

Feel free to post back if you want to troubleshoot further or have other questions.  Additionally, if your Premiere is less than a year old from date of purchase, then may qualify for replacement from Roku. 

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos
Laurassanchez
Level 7

Re: 3920x showing low signal to WiFi after system update.

Made all the adjustments to the router, analysis of the wifi shows no problems but now it's telling me there's no wireless signal anymore. It sees the network, I'll put the password in and then it tells me there's no network to connect to. Error 007 or 014.30

0 Kudos
AvsGunnar
Community Streaming Expert

Re: 3920x showing low signal to WiFi after system update.

@Laurassanchez 

Here is Roku's common error codes and their suggested fixes.   https://support.roku.com/article/208755728

I didn't come up with anything with error code 007, but error code 14.3 generally is linked to either a password issue or other authentication issue between the Roku and the router.  Hence, Roku's suggestion to restart both the device and the router.  Sometimes this simply resolves the issue and may require an extended restart of both (unplug both for a bit, and then reboot).

The other suggestions I would try in this order....

1.  Remove the network password from the router for both the 2.4ghz and 5ghz bands. (SSID passwords, not the router admin password).  Then restart router and Roku and try to connect.  If you are using a single/merged network you will only have a single SSID password.

2. If unsuccessful, and with passwords still disabled, navigate to Roku Settings...System...Advanced System Settings...Network Connection Reset...Reset Network Connection.   The Roku should reboot automatically.   When Roku loads, navigate to Network Connection, press Scan Again to Refresh Connections, and then try to connect to your 2.4ghz connection. 

3. If using a single/merged network, try splitting your network into a dual network.  Seperate names for both the 2.4 ghz and 5 ghz bands.  When using a merged network, some router settings are universally applied to entire network affecting the SSID frequencies differently.

4. If still unsuccesful, then final two options is to factory reset the router. (normally press reset button, not power button, for 20 sec or so or until the LEDs flash a different color).  Here I would use router's automatic settings and see if I could connect before changing anything to the recommended settings of the 2.4 ghz settings I recommended above.  If it does, then change to recommended settings regarding channel and bandwidth and should still be able to connect.  The second and final option is to factory reset the Roku Premiere. (I have never had to do this, but this is the fail-safe to restore Roku and remove corrupted settings.)

If you exhaust this list, then you have pretty much exhausted network issue and are left with a device issue/failure needing replacement.  This is often why some people just purchase a replacement and see if that remedies the issue rather than troubleshoot.  Narrowing down network issue versus device issue can be timely.

In any case, the password disabling is just for troubleshooting purposes.  Remember to enable a SSID password again if you get resolved in any step of the troubleshooting above.

My ISP is currently going under some maintenance upgrades this weekend and I now have intermittent speeds between 1mb and 4mb and all my Rokus are behaving differently (some showing connected but disconnect as soon as I stream...others not showing internet connection at all, most likely due to slow speed detected).  The only one staying connecting and streaming at all is my Premiere when speed drops to 1mb and below.  As such, sometimes the error codes provided by Roku is more a guideline, not a true diagnostic code.  I am currently seeing various versions of error codes 12, 14 and 16, all attributable to my speed and how my various routers are working through this maintenance, and what the Roku is interpreting as fault.

Feel free to post back again when you get resolved or need more help.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos
Laurassanchez
Level 7

Re: 3920x showing low signal to WiFi after system update.

I have done all these steps and continue to have the same issue. At this point in time I feel like it might be a hardware issue since the Roku will now just reboot itself randomly. 

0 Kudos
AvsGunnar
Community Streaming Expert

Re: 3920x showing low signal to WiFi after system update.

@Laurassanchez 

Agreed.  You have exhausted all reasonable troubleshooting steps which unfortunately leads to device issue/failure.

If your device is less than a year old, should qualify for warranty replacement.

https://support.roku.com/article/208757058

Good luck, sorry it wasn't an easy fix.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos
Laurassanchez
Level 7

Re: 3920x showing low signal to WiFi after system update.

This thing isn't even 3 months old. 

0 Kudos
gered45
Level 7

Re: 3920x showing low signal to WiFi after system update.

I didn't give you some thing with errors code 007, but error code 14.Three normally is related to both a password difficulty or different authentication issue between the Roku and the router. Hence, Roku's inspiration to restart both the device and the router here. Sometimes this virtually resolves the issue and can require an extended restart of each

0 Kudos
AlejandroG
Level 7

Re: 3920x showing low signal to WiFi after system update.

I had a 3921X that was giving me the same issue. I was resetting routers and moving WFI extenders and I realized it was not my local network. I ran a speed test with my mobile phone and was seeing an extremely fast connection. When I ran the Test the Network connection it showed a bad or slow network. I took an Roku older streaming stick I had laying around and it connected perfectly with 89M. My warranty expired two weeks after the 1 year warranty date June 3rd and the support site does not even recognize the SN. Once I dug deeper, the 3921X does not even have support. I'm disappointed with Roku's latest products. They are cheaply made and offer no support.

0 Kudos
StreamerUser
Level 20

Re: 3920x showing low signal to WiFi after system update.

@AlejandroG

The 3921 (Premiere+) is supported by Roku:

https://developer.roku.com/docs/specs/hardware.md

However, as a lower end model it is not available for AGENT-ASSISTED support (you have to read the support articles/use support tools/community/etc yourself):

https://support.roku.com/article/208757038

The higher end models are available for agent-assisted support.

Yes, its poor limited customer service, but its not "no customer service" or "not supported".

They are "cheaply made" devices (welcome to consumer electronics), and the low-end ones are also cheap to buy

0 Kudos