Getting Started - Setup & How-to

Help getting started with Roku devices, including setup, connecting your device to your TV, linking a Roku device to your account at my.roku.com/link, adding channels, subscribing to services, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
gary4
Level 7

no set up link

Hello After having issues setting up DNS ive had to factory reset a few times . The DNS is now set up correctly on router but there is no new link arriving , tried to rest many times but no luck.Grateful if anyone has any ideas or what to try next , or what the issue could be , thanks !

 

0 Kudos
4 REPLIES 4\
Tivoburkee
Community Streaming Expert

Re: no set up link

When you're factory setting is the Roku powered? And are you pressing the key, jor abbing something into the pinhole for at 50 seconds to reset?

Edmund
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
gary4
Level 7

Re: no set up link

Hi Tivburkee

I tried the resore to default factory setting with the remote control then for 50 seconds , both powered up and not connected.

Error message says 'unable to connect to Roku service'

Network settings are OK, everything else on same router is fine.

Tried unlinking device that i set up yesterday , but nothing working so far

 

Thanks

0 Kudos
gary4
Level 7

Re: no set up link

*THEN 50 SECONDS WITH PIN

0 Kudos
gary4
Level 7

Re: no set up link

 

I just came across this post from someone , maybe same issue ?

 

Re: Activation code not displaying

My ISP changed my static IP to a DHCP assigned IP...  problem went away...   I had DAYS and DAYS of diagnosis and everyone not understanding what I was trying to communicate to them.  I did ALL the diagnosis steps all parties made me do, including me finding the "secret screen" hack.  All connectivity tests there worked  I used "ping" and speed tests and green checks from third party apps (Netflix and ROKU)  all showed good or better and connectivity existed.

Still no authorization code...  Local ISP and I hashed it out.... a "last ditch" attempt to "try something" ended up changing my static IP to a DHCP assigned IP....    Problem now gone....    

Just add this to your diagnostic trail to help customers in the future...   It might be worth a try....  

0 Kudos