Getting Started - Setup & How-to

Help getting started with Roku devices, including setup, connecting your device to your TV, linking a Roku device to your account at my.roku.com/link, adding channels, subscribing to services, and more.
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Dreamsayer
Level 8

[Solved] Roku Alexa Skill

Jump to solution

Roku Alexa Skill is not working! I receive an error "Sorry we could not find any devices to link." There are 243 other people on the Amazon Roku Skills forum with 1 star reviews stating the same problem.

 Express | Easy High Definition (HD) Streaming Media Player

Thanks!

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
Dreamsayer
Level 8

Re: Roku Alexa Skill

Jump to solution
Spoke to Amazon support. The reason this is not working is because both devices need to be on the same network band. My Roku and Amazon Dot are on different WiFi bands. Echo on 5Ghz, and Roku on 2.4Ghz. Unfortunately I have Google WiFi and there is absolutely no way to separate them. The system picks the fastest network for the device. Since the Roku Express does not have 5Ghz support I am unable to confirm this.

View solution in original post

0 Kudos
17 Replies
Community Manager
Community Manager

Re: Roku Alexa Skill

Jump to solution
Hi there! 

Thanks for reaching out. Sorry to hear about the hiccup you're running into!

Try following the steps here and setting up the Roku skill for Amazon Alexa again: https://support.roku.com/article/360017961074-how-do-i-use-amazon-alexa-with-my-roku-streaming-devic...

Please let us know if you're still running into an issue from there. 


Cheers,
Tanner
Tanner D.
Roku Community Manager
0 Kudos
Dreamsayer
Level 8

Re: Roku Alexa Skill

Jump to solution
Hi Tanner,

I followed those instructions to the T. It is not working. I've checked my Roku for updates (up to date), powered it off/on, powered off/on my Dot, removed skill reinstalled skill. I receive a confirmation that Roku has been successfully linked, then Alexa is looking for devices, then Sorry could not find devices. I tap on discover devices again and still the same error. I initially tried this a week ago with the same problem and decided to try again today. No change. 

Please advise.

Thanks,
Frank
0 Kudos
Dreamsayer
Level 8

Re: Roku Alexa Skill

Jump to solution
Why is ROKU silent on this issue? Lot's of unhappy customers. Go check the Amazon Skills reviews.

https://www.amazon.com/Roku/dp/B07KCPWH27/ref=cm_cr_arp_d_product_top?ie=UTF8
0 Kudos
mikebdoss
Level 10

Re: Roku Alexa Skill

Jump to solution
"Dreamsayer" wrote:
Why is ROKU silent on this issue? Lot's of unhappy customers. Go check the Amazon Skills reviews.

https://www.amazon.com/Roku/dp/B07KCPWH27/ref=cm_cr_arp_d_product_top?ie=UTF8

Roku is regularly silent on these kinds of things, and it's annoying. 
0 Kudos
Dreamsayer
Level 8

Re: Roku Alexa Skill

Jump to solution
Spoke to Amazon support. The reason this is not working is because both devices need to be on the same network band. My Roku and Amazon Dot are on different WiFi bands. Echo on 5Ghz, and Roku on 2.4Ghz. Unfortunately I have Google WiFi and there is absolutely no way to separate them. The system picks the fastest network for the device. Since the Roku Express does not have 5Ghz support I am unable to confirm this.

View solution in original post

0 Kudos
atc98092
Level 16

Re: Roku Alexa Skill

Jump to solution
Try giving your 2.4 and 5 GHz networks different SSID names. I'm not familiar with connecting the Dot, but if it gives you any choice of networks (I would hope it would) then you can specify the one you want. If both frequencies have the same SSID, I'm sure it will always choose the 5 GHz connection first. 
.
I'm not sure I accept Amazon's explanation. As long as both wireless devices are connected to the same overall network, I can't see how one being on 5 GHz while the other is on 2.4 GHz could matter. The Roku and Amazon aren't communicating directly with each other wirelessly, they are using the underlying network connection, which has nothing to do with the wireless frequencies in use. Unless there's a setting in your router that is separating the two frequencies into to separate sub-networks, sometimes labeled VLANs. Of if your router has a setting enabled that blocks one wireless devices from seeing another. Those exist as well, usually for privacy from guest connections. 
Dan
Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
Dreamsayer
Level 8

Re: Roku Alexa Skill

Jump to solution
Unfortunately I cannot give my networks 2.4 and 5 GHz bands different SSID names. Not supported. I know what you mean, my old router did that. I have the Google WiFi system now. It came with 3 pucks you spread around your house for whole home coverage.

From their documentation:
Your Wifi point(s) keeps it simple by automatically choosing the band that gives you the best Wi-Fi. Your Wifi point(s) uses the same name for both the 2.4 and 5GHz band networks. This means your Wi-Fi network uses both radio bands. This method is different from many routers. Some other routers have two separate Wi-Fi networks (one for the 2.4GHz band and another for the 5GHz band), which require you to manually connect to the band you want. We believe Google Wifi’s method provides a better, easier experience.

And I completely agree with your statement "I'm not sure I accept Amazon's explanation. As long as both wireless devices are connected to the same overall network, I can't see how one being on 5 GHz while the other is on 2.4 GHz could matter."

I guess I'm just SOL using the Roku Alexa skill. Which from what I've read doesn't do all that much anyway..
0 Kudos
blade_005
Level 11

Re: Roku Alexa Skill

Jump to solution
"Dreamsayer" wrote:
I guess I'm just SOL using the Roku Alexa skill. Which from what I've read doesn't do all that much anyway..

I can't address your WiFi issue, but I have read through the reviews on Amazon about the Skill and have tried to respond to some of the issues and frustrations expressed there. I do hope you get your WiFi issue resolved and can get your Roku devices discovered in the Alexa app and Roku Skill. The skill does offer quite a few features once you get it set up and apply the proper syntax when issuing commands. Though the documentation states only one Roku device can be controlled, I have set up three (3) TCL Roku TV's that can be controlled. The caveat is that you must link an individual Echo speaker to each device. If you have an Echo device to dedicate to each Roku device then you can set up multiple Roku devices.

I have found the following controls with the Skill to be quite useful.

  • Control of multiple Roku devices if able to link specific Echo speakers to each device.

  • TV ON/OFF with Fast Start enabled on Roku TV.

  • Set VOLUME to specific number level on Roku TV.

  • Open many popular apps with Voice command. Even though Netflix app is not supported for Open, a SEARCH for Netflix item will bring up TV Show / Movie and then a remote click will jump you right into item without navigating the Netflix home screen deluge of auto trailers.

  • PAUSE/RESUME Video stream.

  • Change to specific channel using OTA antenna on Roku TV.

  • Change to specific HDMI input on Roku TV.

  • Search for specific Movie / TV Show for quicker access.

  • Roku OS 9.1 update now allows for commands to PLAY 'TV SERIES / MOVIE' on specific app (i.e. Hulu, Roku Channel) and it will start up the appropriate app and in the case of a TV Series on Hulu or Roku Channel it will start up the TV Series on your last Resume point or the NEXT UP episode in your list.

My point is that the Skill is worth pursuing if you can get your WiFi issue resolved. The Amazon reviews are mostly negative as you would expect from most feedback responses. Frustration and minimal effort win out.
TCL-TV Roku 55P605 (4K HDR & DV) | VIZIO SB36512‑F6 Soundbar
TCL-TV Roku 43S425 (4K HDR) | TCL-TV Roku 32S301 (720p)
0 Kudos
Dreamsayer
Level 8

SOLVED Re: Roku Alexa Skill

Jump to solution
I disconnected my current router. Hooked up an old Netgear WGR614 from the ole' hardware junk drawer. Set it up using the same SSID name and password as current. Confirmed Echo dot and Roku were connected to network. Ran the Alexa skill and VIOLA! It's connected and working now. Disconnected Netgear and put back my current Google WiFi router. Still works!!

I guess Amazon was correct about both devices needing to be on the same band. Either that or the Google WiFi mesh system is wonky!
0 Kudos