Getting Started - Setup & How-to

Help getting started with Roku devices, including setup, connecting your device to your TV, linking a Roku device to your account at my.roku.com/link, adding channels, subscribing to services, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
afredric
Level 7

Setup started, the nothing and can’t get back

I’m trying to setup a new Roku Premier.  I selected English, recognized my network, got half way through my password and screen went dark - couldn’t get back to setup.  I’ve tried to reset the device, reset my network, switched HDMI ports...nothing.  Blinking blue light or steady blue light.  No menu, no nothing.  I have an older Panasonic but not so old that it doesn’t have two HDMI ports (my DVD player was in the port and worked just fine).  Any suggestions?  Otherwise, sending back tomorrow.  Roku in my cabin works perfect but here, not so much.  It shouldn’t be this hard.

0 Kudos
1 Reply
AvsGunnar
Level 10

Re: Setup started, the nothing and can’t get back

Wondering since you said you have older Panasonic if maybe there was a video misconfiguration during setup.  See if you can change your TV to 720p, unplug your HDMI, do the factory reset again (need to press and hold that button for at least 15 sec, I'd say 30). Make sure you are plugged into power outlet/wall not tv  power for setup. (Also, make sure you are powered when doing the reset)

If you are able to get it to boot up again, select 720p when Display Settings Screen appears instead of Auto Detect or the like when prompted by Roku.

There is a chance you can access the Roku using some remote control debugging codes to do these things, but try the above first.  You may not have held button in long enough for factory reset to occur. 

https://support.roku.com/article/208757008     factory reset

See if that helps.

0 Kudos