Getting Started - Setup & How-to

Help getting started with Roku devices, including setup, connecting your device to your TV, linking a Roku device to your account at my.roku.com/link, adding channels, subscribing to services, and more.
cancel
Showing results for 
Search instead for 
Did you mean: 
Cthulhu
Level 7

Roku Express setup issue

Jump to solution

Hi Tanner.  I can't past the opening screens on my new Roku+ either.  I get asked for language, then the password for my wifi, which it refuses to accept or connect.  So I can't egt anywhere near the screens that are needed to do a factory reset.

Can you clue us in on why this is happening?

0 Kudos
Roku Employee
Roku Employee

Re: Roku Express setup issue

Jump to solution

Hi,

Thanks for letting us know about the issue that you are experiencing.

I would recommend checking out our Support page for troubleshooting issues here: What should I do if I cannot connect to my home network or the internet?

Have you ensured your router is broadcasting a 2.4GHz Wi-Fi network for the device to connect to? The Roku Express is only compatible with wireless b/g/n networks on the 2.4 GHz spectrum. We would also recommend that you try changing your WiFi password to see if you device will connect.

Please keep us posted!


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
pd123
Level 7

Setting up Express +

Jump to solution
I previously had an older Roku and just bought the Roku express plus . I connected the HDMI cable to the TV into the box (like my old one was), put the TV on hdmi 2, and connected the power source to Roku then to the outlet . I got the word Roku then dancing on the screen but then nothing after . It didn’t bring me to another set up screen . I’ve tried resetting the box, resetting everything , any ideas?
0 Kudos
ergordon4
Level 7

Sony Wega TV and Roku Express - set up starts, then screen goes black

Jump to solution

We have the last Sony WEGA HD flat screen CRT TV, which does have an HDMI port. When I plug the Roku Express (3930, 3931 series)  into the HDMI, I can choose the language, choose the Wifi, enter the password, then it shows that it did connect, then the screen goes black and that's it. When I tried a factory reboot, I saw the Roku screen saver while it rebooted, then the same thing happened. I tried setting it up on a different TV to make sure the unit was not defective; it worked fine. Once set up, I connected it again to the Sony TV, and every time I clicked on the correct input, I saw the home screen for a couple of seconds, then it went black.

Can someone PLEASE help me? 

0 Kudos
LanceE
Level 8

Re: Out of box Roku Express doesn’t setup and appears locked

Jump to solution

ok anyway, that unit was returned to sam's for refund. the end of part I.

Now for Part II.

Went to wal mart and got another Roku Express,

again same thing, things went smoothly until it auto downloaded a new update.

after that it was one issue after another to get through the setup process.

then the wireless connection died after about 2 hours of use.

there is nonthing that can be done to revive it.

so that unit got returned to wal mart today.

11/20/2019. seems like ROKU is having quality control issues in in their firmware or production of the product.

Now Roku did respond to my 1st post, but then deleted it.

I guess they don't like what I have to say.

 

0 Kudos
Community Manager
Community Manager

Re: Sony Wega TV and Roku Express - set up starts, then screen goes black

Jump to solution

@ergordon4 Thanks for the note here. A few questions: 

- What is the specific model of Sony TV that you are trying to connect the device to when you encounter the issue?

- Have you tried all of the HDMI ports on the TV to see if the same issue occurs? 

- Are you trying to use any kind of video signal converter or adapter? (Note: These are not technically supported setups, so results may vary.)

 

Thanks,

Tanner

 

Tanner D.
Roku Community Manager
0 Kudos
Community Manager
Community Manager

Re: Out of box Roku Express doesn’t setup and appears locked

Jump to solution

For anyone who is still experiencing this issue, please post the specific make & model of TV that you are trying to connect your device to when you encounter the issue during setup and see a blank/black screen. This information helps our team investigate your reports. 

Please also send me a private message with your Roku account email address and the serial number of your Roku device (printed on the unit). I'll continue working with you to see what else we can recommend. 

 

Thanks,

Tanner

Tanner D.
Roku Community Manager
0 Kudos
ergordon4
Level 7

Re: Sony Wega TV and Roku Express - set up starts, then screen goes black

Jump to solution

The model of the TV is FD Trinitron Wega KV-32HS420. There is only one HDMI port.

Normally we have the Denon Receiver connected there, and everything goes through the receiver. I wanted to test directly on the TV to make sure it wasn't the receiver. I get the same result if I connect through the HDMI on the receiver, or the HDMI on the TV. I am not using any video signal converter or adapter (not even sure what that is). 

0 Kudos
Community Manager
Community Manager

Re: Set up screen still showing after setting up my account

Jump to solution

Hi there, 

Thanks for the note. Please see more information and our helpful setup video here to help you get setup and link your device to your Roku account: https://community.roku.com/t5/Getting-Started-Setup-How-to/Setup-and-Getting-Started-with-Your-Roku-...

Our setup videos will walk you through the entire process step-by-step, allowing you to stop/pause or rewind the tutorial as needed while you complete the setup process. 

 

Thanks,

Tanner

Tanner D.
Roku Community Manager
0 Kudos

Roku Express can't get past display type screen setup

Jump to solution

I just got a new roku. Hooked it up and it only shows the roku set display type screen. I can get off this screen. I've tried using back button home button unplugging and resetting it. And when I click okay on it. It just stays at a blank screen for 30mins and counting. How do I go around doing this

[post moved to appropriate board]

0 Kudos