Getting Started - Setup & How-to

Help getting started with Roku devices, including setup, connecting your device to your TV, linking a Roku device to your account at my.roku.com/link, adding channels, subscribing to services, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
AtMomsHouse1
Level 8

Re: Roku 4k streaming stick and auto detect display type issue

We are having the same issue described above.

 

We have a Samsung 4k hdr tv (model UN65NU6950F) and a Roku model 4800x.

We reset the Roku by long-pressing the reset button under the Roku. We began setup, and got stuck on a loop with the "auto detect display type" screen.

The Roku will auto detect display type and ask if I want to "Use automatic." I click that. The TV flashes black, then  says there is no source, then the Roku reloads but a Display Type prompt appears. The prompt says "You didn't confirm the new selection, so the previous setting is restored." The setting reverts to 720p, instead of 4K HDR.

 

I press OK on the prompt. It brings me to a Display Type selection screen, where 720p is selected. I can choose to Keep Auto Detect, or select from a list of options Including 4k HDR. No matter what I select, it takes me back to the "auto detect display type" screen and the process starts over.

I replaced the batteries in the remote, just in case. Same loop issue continues.

If I go through the "auto detect display type" process and click cancel to try and move on, it puts me back on the "Display Type" screen with a list of options to choose from. Again, no matter what I select, I cannot get out of this loop.

0 Kudos
AtMomsHouse1
Level 8

Re: Roku 4k streaming stick and auto detect display type issue

UPDATE: (solution at the bottom, but I'm including all my troubleshooting efforts in hopes Roku will be able to resolve this issue.)

 

Someone else suggested plugging the Roku into a different monitor to force it through this "auto detect display setting" loop. I tried that. I plugged the Roku into an older Samsung 1080p HD TV (model UN46C7000WF).

I let the Roku autodetect display; it detected the 1080p tv, then led me to the Display Type screen to make a selection, like before. I selected 4k HDR. The Roku ran it's autodetectiom again, but this time it gave me the option to "force output to 4k uhd HDR". I selected that.

The screen went blank for about 10 seconds.

Then the same prompt appeared, saying "you didn't confirm the new selection, so the previous setting is restored."

So I tried going back to the Display Type screen and selecting "Keep automatic." This ran the autodetect cycle again but something different happened: a new prompt appeared, asking if I wanted to "Yes," keep the newly selected setting, or "No," make changes. ("No" is highlighted by default.)

I thought that maybe this yes/no prompt was appearing when the screen went black. And the message saying "you did not confirm the setting" was appearing because the yes/no prompt was appearing during the black screen. So maybe I could select Yes while the screen was black, if I timed it right. Then I could force the Roku into the 4k display setting, and then connect the Roku to my 4k display.

(Notes on timing: it's about 5 seconds of blank screen time as the source/roku and the monitor/Samsung refresh, then the prompt appears asking me to click "yes" or "no" to confirm or reject the display setting. I have to move the cursor up once to select "yes.")

So I went back to the Display Type screen and selected 4k HDR. Roku ran the autodetect cycle, said my display tv wasn't a match (since 8 was still plugged into the old 1080p monitor), then Roku asked if I wanted to "force" the display setting to change to 4k hdr. I clicked that to force the 4k setting.

Then the screen went black, I waited 5 seconds, then while the screen was still black, I clicked the cursor up and clicked okay on the remote (to select the "yes, keep this setting" option, even though I couldn't see the option on screen).

The screen stayed black after I made my selection. So I then switched the Roku back to my main (4k HDR) tv, thinking I have now forced the Roku to the 4k HDR display selection, and it will now work.

Nope. The Roku now does not talk to the Samsung 4k tv at all. The TV cannot detect any signal from the source/roku, despite me seeing the Roku is powered on and is receiving my Roku remote signals (as shown by the white light on the front of the Roku). I tried turning the TV off and back on again, but it's still not able to detect a signal from the source/roku.

So I unplugged the Roku, waited 30 seconds, and plugged it back in. The TV received the source signal while the Roku started up, but then promptly went back to being unable to detect a signal.

So I plugged the Roku back into the old 1080p TV. The setup process had moved forward to the next step after selecting display: connecting the remote. Roku let me continue all the way through the setup process while connected to the old 1080p tv, and the Roku worked.

But when I plugged the Roku back into the new 4k tv again, the tv still could not detect a signal from the source.

 

I think the issue may have to do with the new Samsung TV automatically adjusting picture quality when the new source (Roku) is plugged in. I think this creates a barrier, where the tv is trying to detect/optimize display output options available from the Roku, while the Roku is trying to detect the display type from the TV. It's like they are butting heads about the display type. (Maybe.) Whereas the old 1080p tv isn't trying to detect/optimize the display output from the Roku — the tv just lets the Roku detect its display type, and everything works.

 

Soooo, I reset the Roku again by long-pressing the reset button under the device. Got to the "auto detect display type" setup step. Tried my "blank screen + select the invisible Yes option" method again, but this time I was on the 4k HDR tv when I tried it. Same result, where as soon as I do that and select the invisible "yes" option, the tv no longer detects any signal from the Roku source.

I reset the Roku again with the button under the device. I went into my TV settings and tried to reset picture settings. Roku setup still failed.

I tried checking for a software update for the Samsung 4k HDR TV. Nope, it's updated to the current version (1325).

I tried looking for other tv settings about external devices, display/picture, or anything I might be able to turn off to fix the issue it was having when Roku tried to detect the TV display. Nothing.

 

SOLUTION:

While connected to my Samsung 4k hdr tv, I went back to the Roku setup process (after resetting the Roku again), and got back to the "auto detect display type" screen. This time I pressed cancel.

It took me to the "display type" selection screen. This time I selected the default 720p display type (for my 4k HDR tv — sad). It let me out of the "auto detect display type" setup loop and I was able to finish the Roku setup successfully.

 

Note: Once you're fully setup, you could go to the Roku Settings > Display Type > and select a display setting from the list. DO NOT DO THIS because it results in the same issues outlined above. You *must* keep the 720p settings or the Samsung TV will say there is no signal from the source/Roku.

0 Kudos
renojim
Community Streaming Expert

Re: Roku 4k streaming stick and auto detect display type issue

@AtMomsHouse1, using 720p on a 4k TV doesn't seem like a good solution.  What if you try to get through the auto detect display setting blindly?  After you select 4k HDR and your screen goes blank try pressing the Up arrow on your remote and then OK.  That should set it to 4k.  You may have to unplug the HDMI cable and/or the power cable and reconnect them or worse case have to reset it and start all over.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
AtMomsHouse1
Level 8

Re: Roku 4k streaming stick and auto detect display type issue

@renojim 

"What if you try to get through the auto detect display setting blindly?"

 

I attempted that and described the negative results in the long post above.

Unfortunately it results in the Samsung being unable to detect a signal from the Roku, and there is no solution (that I could find) other than to fully reset the Roku and start all over.

 

Edit:

But I agree that using 720p on a 4K is not a good solution. It is just the only working solution I could find in 2 hours of troubleshooting.

I believe the only solution (for 4k output) may be for Samsung or Roku to release an update that fixes the issue around Samsung's auto "display optimization" feature — which I suspect is creating the conflict. Roku tries to detect the display type (Samsung's 4k HDR), while Samsung tries to optimize the display from the source device (Roku), and something gets stuck where Samsung can no longer detect any output signal from Roku.

Maybe I'm wrong! And if there's a solution I haven't tried above, I'd be happy to give it a shot.

0 Kudos
Mde
Level 7

Re: Roku 4k streaming stick and auto detect display type issue

Same problem for me.

New roku, plugged it into TV, got WiFi connected and then stuck on the hdmi auto detect screen.  The unit is completely frozen 

0 Kudos
AtMomsHouse1
Level 8

Re: Roku 4k streaming stick and auto detect display type issue

@MdeMay I ask what is the tv you're using — make and model#?

(Just wondering if it is a newer Samsung like ours?)

0 Kudos
lgwal
Level 7

Re: Roku 4k streaming stick and auto detect display type issue

Just wanted to share my solution since I had the same issue (frozen 'Auto Detect Display Type') and managed to fix it.

Before connecting the Roku Streaming Stick 4K, I changed a setting for my TV (Samsung Series 7 4K):

Settings -> Picture -> Expert settings -> Apply Picture Settings -> Here I changed it from "All sources" to "Current source"

Not sure why it worked, but after I changed that, I plugged in the Roku device and the setup process worked - maybe it will work for you too!

0 Kudos