Getting Started - Setup & How-to

Help getting started with Roku devices, including setup, connecting your device to your TV, linking a Roku device to your account at my.roku.com/link, adding channels, subscribing to services, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Roku Employee
Roku Employee

Re: Defective Roku after software update

Jump to solution

@Zacskev 

Thanks for the inquiry.

We recommend rebooting both your wireless router and your Roku device. Alternately, I'd also recommend trying to connect your device to an alternate network or mobile hotspot.

Please make sure that when trying to perform a factory reset on your device that you hold down the reset button for 30 seconds regardless of what is happening on the screen.

Keep us posted with what you find out. 


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Highlighted
Level 7

Re: Defective Roku after software update

Jump to solution

Thanks for the response Danny, I've reset my internet modem, factory reset the device for 30 sec a few times, tried different tvs and have even hot spotted off my phone. It allows me to Pick language, pick internet, download new software but when it reboots it just sticks on the jumping Roku icon for hours.

What do you recommend?

0 Kudos
Highlighted
Roku Employee
Roku Employee

Re: Defective Roku after software update

Jump to solution

@Zacskev 

Thanks for the note.

Please send me a PM with your Roku account email address, and include the serial number of your Roku device (printed on the side/back of the device). I'll be able to assist you further from there.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Highlighted
Level 9

Re: Defective Roku after software update

Jump to solution

@Zacskev wrote:

Thanks for the response Danny, I've reset my internet modem, factory reset the device for 30 sec a few times, tried different tvs and have even hot spotted off my phone. It allows me to Pick language, pick internet, download new software but when it reboots it just sticks on the jumping Roku icon for hours.

What do you recommend?


Move it closer to the WiFi source if it's not Full bar/100% signal. Change the HDMI cable, don't use the included cable. I recently posted in another thread for possible solutions to setup problems.

0 Kudos