Getting Started - Setup & How-to

Help getting started with Roku devices, including setup, connecting your device to your TV, linking a Roku device to your account at my.roku.com/link, adding channels, subscribing to services, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

My new Roku Ultra LT has no signal on my Insignia ns-46e481a13 LED 180p 120Hz HDTV.

Jump to solution

My new Roku Ultra LT has no signal on my Insignia ns-46e481a13 LED 180p 120Hz HDTV. I don't think the Roku is powering up.  I've tried multiple HDMI ports and cables.  I've also tried different power outlets.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Level 7

Re: My new Roku Ultra LT has no signal on my Insignia ns-46e481a13 LED 180p 120Hz HDTV.

Jump to solution

Same problem with another TV, I went back to the store and swapped it out with another Ultra LT and was able to set it up in minutes, it appears that either the device or the power cord was defective.  The new one works great.

Thanks. 

View solution in original post

0 Kudos
2 Replies
Highlighted
Roku Employee
Roku Employee

Re: My new Roku Ultra LT has no signal on my Insignia ns-46e481a13 LED 180p 120Hz HDTV.

Jump to solution

@caissienj 

Thanks for the inquiry.

Have you tried connecting your device to another TV? We would recommend testing to see if your device will connect to another TV to figure out if it's your device or TV that has the issue.

Please keep us posted.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Highlighted
Level 7

Re: My new Roku Ultra LT has no signal on my Insignia ns-46e481a13 LED 180p 120Hz HDTV.

Jump to solution

Same problem with another TV, I went back to the store and swapped it out with another Ultra LT and was able to set it up in minutes, it appears that either the device or the power cord was defective.  The new one works great.

Thanks. 

View solution in original post

0 Kudos