Getting Started - Setup & How-to

Help getting started with Roku devices, including setup, connecting your device to your TV, linking a Roku device to your account at my.roku.com/link, adding channels, subscribing to services, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
RokuDanny-R
Roku Employee
Roku Employee

Re: Express set-up - rejection of known valid WIFI password

@rrogers0613 @jazzer94 

Thanks for the post.

We would recommend taking a look here for more tips about troubleshooting that network error code: What should I do if I cannot connect to my home network or the internet?

Please keep us posted what you find out.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
jazzer94
Level 8

Re: Express set-up - rejection of known valid WIFI password

What I'm finding out is that I have already done and posted that I have done all of the things (see all of my posts about this issue throughout this forum).  Please stop sending out the "boilerplate" response.  What I would like right now is for someone from Roku to contact me so that I can return this unit and get my money back.  This update has made my device no longer functional and therefore I would like my money back.

0 Kudos
RokuDanny-R
Roku Employee
Roku Employee

Re: Express set-up - rejection of known valid WIFI password

@jazzer94 

Thanks for the update.

If you have tried all the troubleshooting steps provided by our Support page and still need further assistance with your issue, please send me a PM with your Roku account email address, and include the serial number of the Roku device from Settings>System>About along with a summary of the troubleshooting steps you have taken. I'll be able to assist you further from there.

 

Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Renee930
Level 7

Re: Express set-up - rejection of known valid WIFI password

I’m also in this boat all my other devices are connected to my WiFi network. I know my password, I’ve used it for my other devices. My Roku sees my network asks for my password then will not accept it and yes it’s easy and correct. No special characters. So please I know how to put in my password. The nice thing is I’m obviously Not alone in my password dilemma. Does anyone have a fix for me? 

0 Kudos
RokuDanny-R
Roku Employee
Roku Employee

Re: Express set-up - rejection of known valid WIFI password

@Renee930 

Thanks for the post.

If you are not able to resolve the issue, please send me a PM with your Roku account email address, and include the serial number/device ID on the Roku device along with a summary of the issue you are experiencing. I'll be able to assist you further from there.

 

Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Poterico2
Level 10

Re: Express set-up - rejection of known valid WIFI password

Here's 2 solutions from out in left field, but you might not like them;

1. Reset the password on you wifi router.  It should solve the problem, but you would have to re-sign in to all your other devices as well which is a pain!

2. Buy a new unit and try it again. maybe there's something wrong with your current one.

I hope this helps!

0 Kudos
gangbuster
Level 7

Re: Express set-up - rejection of known valid WIFI password

I was having the same problem - rejecting passwords. I even tried connecting to an open network with no password and it would not connect. I looked at my router and it saw the device's hardware address, so the router could see the device. I then changed my router's wifi type from 802.11/g/n to 802.11/b/g/n and it worked! This is an xfinity router. 

DSH3
Level 7

Re: Express set-up - rejection of known valid WIFI password

Wow!! I had the exact same problem with my brand new Roku Express! I have an xfinity Gateway modem/router also and went on a xfinity site search to see if I had 802.11/g/n or 802.11/b/g/n. After about 45 min of a real "down in the weeds search" on my xfinity acct. I found the page which gave this info and sure enough, for some reason, xfinity had it set at 802.11/g/n. This page gave me the option to change it to "b/g/n", which I did. I then went and tried the Roku Express activation and it went through flawlessly. I thought for sure, as others have, that I had a defective device. This whole episode is rather disturbing because the fix is so obscure that regular people would have no idea how to fix it. I was lucky and just about gave up. Then I read the above post and that was to be my last attempt to activate before I tossed the device and consoled myself as it was discounted by Amazon for Prime members with outdated Roku devices that would not work for Amazon Prime after Nov. 1st. I figured I now at least had a spare remote, USB charger & HDMI cable.  I even spent a few minutes trying to find the xfinity page again for this post, but I could not as it is buried so, so deep on the xfinity website. Strange thing is this device DID connect to wifi several times and then I tried (unsuccessfully, would stall out at about 50%) to download the update. The Wifi connection would disconnect for no reason and I would have to try again. My old 2014 Roku Streaming Stick still worked when I removed it. I installed a Roku3 x4200 device that was given to me after I gave up on the Roku Express (from Roku website) subsidized by Amazon deal. The Roku3 x4200 installed and works flawlessly along with pairing a new voice remote pro that seems to work very well also. I don't know if this issue is something that Roku has missed in their design or software or if it is the Internet service provider dropping the ball and doing something like deciding that 802.11/g/n is a good enough or proper default setting rather than 802.11/b/g/n, which was a choice in the the drop down list on that website page.

marinia745
Level 7

Re: Express set-up - rejection of known valid WIFI password

https://internet.xfinity.com/network/advanced-settings/radio

This might be the page you were looking for?

0 Kudos
marinia745
Level 7

Re: Express set-up - rejection of known valid WIFI password

UPDATE:
it worked. Here's how:
-Go into your Xfinity account, and select the tab that says 'Connect'
-Click on the blue words 'see network
-Click 'advanced settings'
-The first option should say something along the lines of 2.4 and 5GHz WiFi, click on this.
-Above the first of the two sections here you will see a blue 'Edit' word, click on it.
This will allow you to select between the 802.11 g,n and 802.11 b,g,n. You will want to select the 802.11 b,g,n

This seemed to fix the unaccepted password problem for me, but it was VERY frustrating to have to do something so invasive for a 'quick setup' device.

Images for reference.


0.png1.png2.png3.png4.png

0 Kudos