Features, settings & updates

Get troubleshooting tips to configure your Roku settings. The community forum has tips for screen mirroring, Guest Mode, software updates, audio, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Roku factory reset not working?

My Roku is stuck on the jumping Roku homescreen. So I tried to hold the reset button down for 20 seconds to do a factory reset but after a few seconds it just starts up again and is still stuck on that jumping Roku screen. Anyone know how to fix this?


I also tried to reset with the remote 5 home screen button, 1 up button, 2 reverse and 2 fast forward ....and that doesn't work either.

Community Streaming Expert

Re: Roku factory reset not working?


Do you have a model with a SD card slot?  If you have an SC card inserted, try removing it.  An SD card that has gotten corrupted can prevent a Roku from advancing beyond the bouncing R-O-K-O letters startup screen.

For a Factory Reset, the reset button has to be depressed for at least 30 seconds.

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking "Accept as Solution.".

Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X
0 Kudos