Features, settings & updates

Get troubleshooting tips to configure your Roku settings. The community forum has tips for screen mirroring, Guest Mode, software updates, audio, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
JArgoWareS
Channel Surfer

Roku Ultra stuck at 100% Progress, tried hard reset, goes to update software, stuck at 100%, POC

Roku Ultra is stuck at 100% Progress trying to do an update. Never gets past this. Unplugged, wait, retry, same "BLEEP" problem. Reset button on bottom. Goes to do an update and gets stuck at 100%. Tried many times. Same "BLEEP" problem. Any help out there as Roku Support Sucks!!!

Labels (2)
2 REPLIES 2
RokuMary-F
Community Moderator
Community Moderator

Re: Roku Ultra stuck at 100% Progress, tried hard reset, goes to update software, stuck at 100%, POC

Hi @JArgoWareS,

Thanks for posting in the Roku Community!

We appreciate your patience regarding this matter and value your feedback. We understand that you are facing an issue with your Roku device and we're sorry to hear about the experience that's not what we aim for.

To narrow down and resolve this issue, can you please verify how are you powering your Roku device? Is the device plugged into the TV USB port or is it plugged into a wall outlet? Have you already tried performing a factory reset on the device to see if you can get past the loading screen? As a last resort, if you are still experiencing an issue, we would recommend disconnecting your wireless network, then rebooting your Roku device to see if your Roku device is experiencing the same issue. Once the device is getting past the screen, try reconnecting your wireless network.

For more information about how to factory reset your Roku device, visit our Support page here: How to system restart or factory reset your Roku streaming device | Official Roku Support

We look forward to hearing from you and looking closely into this issue. Thank you!


Best regards,
Mary

Mary F.
Roku Community Moderator
0 Kudos
JArgoWareS
Channel Surfer

Re: Roku Ultra stuck at 100% Progress, tried hard reset, goes to update software, stuck at 100%, POC

The device is a Roku Ultra 4640X and is powered by the plugin brick. I had the device using wired to a AT&T fiber optic internet connection. I tried all of the recommended resolutions, even resetting to factory settings. To no avail. Still stuck at the 100% point for an hour. I decided to leave in connected overnight, and low and behold, it said it installed the update. The time of the install indicated it took over 5 hours. Updating the channels after relinking the device had it stuck again for over an hour. Left it and came back sometime later and it finally had the task finished.  I have a 4662X, a 4800X, and a 3960X. They had no problems updating to the version 12 software and did it over Wi-Fi quickly. The unit (4640X) that has the issue taking so long has another problem. It will connect to the Wi-Fi, but not make an internet connection. When using the wired connection, it does connect to the internet successfully. If I were to speculate, I would say the 4640X is having Ethernet packet loss issues in the software or firmware.

0 Kudos
Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.