Features, settings & updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
almiki
Level 8

Receiver doesn't auto-turn on when TV is turned on by Roku

For years, I've had the following setup: Roku Premiere+ plugged into Samsung KS8000 TV (2016), and Yamaha RX-V679 receiver plugged into the TV ARC HDMI port. It worked fine. Specifically, pressing any button on the Roku remote would automatically turn on both the TV and receiver. Which meant the Roku remote was all I ever needed.

I recently decided to upgrade that Roku to a new Roku Ultra LT. After some random issues (mainly no sound), I factory reset the TV and updated the receiver firmware. Then everything worked fine, EXCEPT now pressing a button on the Roku remote does not turn on the receiver, just the TV. I need to then manually switch the TV audio back to the receiver, and then it automatically turns on. After hours of trying to figure it out, here's what I've gathered:

  • When the TV is turned on by the TV remote, the problem does NOT happen: it does automatically turn on the receiver
  • When I use my Chromecast with Google TV device, the problem also does NOT happen, for all HDMI ports. This includes when I press a button on the Chromecast remote, or when I initiate casting from an Android app.
  • The TV and receiver both turn off automatically when I turn off via the Roku (via the on-screen item, or the 'power' button on the remote)
  • The Roku remote volume buttons control the receiver volume, as long as the receiver is on
  • Before I reset everything, there was a period when the new remote was turning on the receiver correctly
  • After resetting things, even the Roku Premiere+ is having the same problem. I never reset anything on the Premiere+ from when it was working, just unplugged it when I got the Ultra LT, and plugged it back in for testing
  • I have enabled "Anynet+ HDMI-CEC" for all HDMI ports
  • The problem happens no matter what port I use
  • The problem happens when the Roku and receiver are the only devices connected to the TV
  • The problem happens when I use the Android Roku remote app
  • The problem happens when I use an Android 'casting' app that wakes up the Roku

I suspect Samsung is mainly to blame here, but what's so confusing is that a) it used to work, and b) it currently works with the Chromecast, which I assume is doing basically the exact same thing as the Roku. I just can't figure out what changed that broke things. Is there some setting in the TV / Roku / Receiver that could explain this?

0 Kudos