Features, settings & updates

Get troubleshooting tips to configure your Roku settings. The community forum has tips for screen mirroring, Guest Mode, software updates, audio, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Reel Rookie

ROKU Ultra loses signal from external USB hdd dock

Brand new ROKU Ultra.  We have very limited internet so I bought it basically to replace an old WD media box and watch movies ripped via Handbrake.

Using a Thermaltake HDD dock, plugged into Roku USB port.  Have tried a few different USB cables.  HDD is 1TB.  It's nearly full of rips done with Handbrake.  This HDD and dock worked without any problems connected to the old WD media streamer.

The Thermaltake is connected to the Roku.  After about a minute the ROKU sees the HDD.  Then I can maneuver to a file and start it.

About one or maybe two minutes later the movie stops and the Roku says "USB device ext1: is no longer available, please choose another device".

I close out, get back to Home, the Roku says there is no USB device but if I give it a minute or so it finally sees the HDD.  Rinse, repeat.

Can anyone tell me why the Roku keeps losing track of the HDD dock?

I think I'll try transferring a movie or two to a USB3 thumb drive.  See if that works. 

0 Kudos
Reel Rookie

Re: ROKU Ultra loses signal from external USB hdd dock

OK, I'm talking to myself and that's never good.  Tried copying four rips to a USB3 thumb drive.

No problems.  Pause even worked!

So the original problem has something to do with all the different files on the HDD in the dock?  When I plugged the dock and HDD into a PC it took a LONG time to stop loading files and bringing up thumbnails.

Or maybe it's transfer speeds?  The dock is USB2, while the Roku appears to be USB3.  The thumb drive I used is also USB3.

0 Kudos