Features, settings & updates

Get troubleshooting tips to configure your Roku settings. The community forum has tips for screen mirroring, Guest Mode, software updates, audio, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Reel Rookie

Re: [OS 10.5] Ultra 4660X channel issues and slowness

Jump to solution

I have an 4670X Roku Ultra.  The 10.5 update has made it unusable.  Like others, it rolled back to 10.0, but then upgraded again to a newer 10.5 build.

Here's my take after a couple of hours of frustration:

From what I can gather, something in the 10.5 builds is interfering with my home wifi.  Since the 10.5 updates, I have a new wifi signal being broadcast from the Roku box called "Direct-roku-###-######".  This signal is being blasted at a power level that actually interrupts my normal household wifi.  That is, no wireless device in my house can use the internet when my Roku is plugged in. This includes phones, iPads, internet radios, and, of course, the Roku.  The Roku says it can't connect to the internet, but it looks like it's own wifi signal "Direct-roku" is blocking itself from accessing the internet. The actual wifi is being overpowered by this mysterious new Roku signal.  If I unplug the Roku, this new wifi signal goes away and my normal wifi starts to work again with my devices.  But there is no way to have my Roku on and have my normal wifi actually work.  So it's a Catch 22.

I think this new signal has something to do with Roku "Direct Connect" and how the Roku talks to it's remotes.  While there is an option to disable DirectConnect in the menus, mine won't let me turn it off as the Roku claims it's currently connected to a smart remote (though I've taken the batteries out of that remote).

I suspect if I could turn off Direct Connect, it would stop broadcasting that mysterious signal.  Then the normal wifi would be able to get through, and the Roku would work again.  But alas....

Of course, this could all be wrong.  I'm just spit-balling.  I'm hoping Roku updates their OS soon.  Christmas break is coming and my kids are going to want to watch some movies.

0 Kudos
Reel Rookie

Re: [OS 10.5] Ultra 4660X channel issues and slowness

Jump to solution

Been doing some testing.  I have FuboTV for my local live TV.  It is the only service that is being effected by this reloading every few minutes problem.  I have watch several shows and live streams directly from other APPS on the ROKU main menu like Peacock, Newsmax, HBO, etc., with no issues.  It is a FUBO issue from what I can  see.  But, I pay for FUBO via my ROKU account and they provide the service.  So, ROKU needs to fix the issue with FUBO.  I bet HULU and other live TV services are doing the same thing.

0 Kudos

Re: [OS 10.5] Roku Ultra experiencing loading channel issues

Jump to solution

Model4662RW - Roku Ultra LT
Serial number YJOOG7052547
Software version 10.5.0 • build 4208-46
Uptime 5 hours 31 minutes
Roku support roku.com/support
Device ID 04597G052547
Network name Kaminski
IP address
Ethernet MAC address 8C:49:62:00:DF:99
Wireless MAC address 8C:49:62:00:DF:98
MicroSD Card not installed
philo playing for about 2 minutes then has a buffering page come up showing 33%

0 Kudos
Retired Moderator

Re: [OS 10.5] Ultra 4660X channel issues and slowness

Jump to solution

Hi everyone,

Thanks for the posts.

If you are experiencing channel playback issues on a Roku Ultra models 4660, 4661, 4662, and 4670, we recommend checking for a manual update to see if the issue is still occurring as we believe this issue is now resolved.

To check for a manual update, navigate to Home > Settings > System > System Update > Check Now. 

If you are still experiencing an issue, we would recommend searching for another thread similar to the issue you are experiencing. We will be closing this thread out.


Danny R.
Roku Community Moderator
0 Kudos

Re: [OS 10.5] Roku Ultra experiencing loading channel issues

Jump to solution

Hi all,

This is what worked for me.

Model: 4670x - Roku Ultra

Software Version: 10.5.0 build 4208-46

ISP: Comcast/Xfinity

Connection: Wired

Network Check Connection: successful

Channels effected: Netflix, HBOMax, Prime Video, Xfinity, Disney+, Hulu, and Roku (I didn't check any others)

Like many here, channels would not load since my Roku auto-updated last night. If I checked for a System update, the Roku appeared to hang a while, and then would restart. I never got a message saying I was up to date, or otherwise.

Reading about possible ISP or DNS issues in this thread, I disconnected my wired connection and tethered the Roku to my Verizon cell phone. Everything works as expected. Channels loaded. I was able to check for a System Update (there was none, but I actually got a confirmation that there was none vs. the Roku rebooting).

Prepared to edit my DNS servers on my router for the next test, I hooked up the wired connection to the Roku and disabled my Verizon wireless tether. The Roku reported 'No connection' on the main screen on the top-right side. I setup the connection on the Roku back to wired. I figured I might as well confirm the channels would not load before editing my DNS settings.

Surprisingly, everything worked again! I can connect to all channels. I'm streaking from HBOMax as I type this.


  • Did you reboot after switching from the tethered Verizon wifi connection back to the Comcast/Xfinity wired connection?
    • Nope.
  • Can you do a System update after this?
    • Yes. The Roku reports that I am up to date, but does not hang/reboot like it used to while checking.
  • Did you actually change your DNS settings on Comcast/Xfinity?
    • Nope. They remain the default Comcast/Xfinity DNS IP's of and
  • I don't have a tethering plan on my cell phone. Any ideas?
    • Maybe see if a neighbor will briefly let you connect to their non-Comcast/Xfinity wifi and see if this works for you? Or a friend's tethered cell connection? Something along those lines.
  • Are you expecting this to be a long term fix?
    • /me shrugs
  • Any other last remarks?
    • I seem to remember something like this happening a year or two ago where basically entire DNS tables had to be flushed out in order to get HBOMax to login... I cannot remember if this was on a Roku or another platform. But something about the Comcast/Xfinity connection required this... This is very anecdotal, just something that pops into my mind. I can't help but wonder if this would have worked then too. And it is worth mentioning that non-Comcast/Xfinity Roku customers are experiencing the same thing now.

Hope this helps someone!

0 Kudos