Features, settings & updates

Get troubleshooting tips to configure your Roku settings. The community forum has tips for screen mirroring, Guest Mode, software updates, audio, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Implementation of Dolby Vision and Dolby Atmos is poor

I've gotten 2 new Roku Ultra's and both have not been satisfactory.  Atmos and Vision are both on a loop constantly testing the screen and audio.  Audio gets interrupted in the middle of a show or Amazon Music.  I have a 55 in. LG OLEG (Smart TV) with Dolby Atmos and Vision.  When I run the same applications off of the LG it doesn't have those problems.  The display setting is (by default) APS, however, the Roku shuts off that setting and I have to either use Cinema or Standard.  Depending on what you are watching the screen is not correct.  The 1st Roku had the same problem, however, after refreshing it would have an HDCP error.

Volume leveling doesn't work properly.  With Volume leveling (* button on Roku Remote) I can comfortably have the volume at 9 or 10 with the Ultra prior to the newest.  With the newest I have to set it much higher.

When you go into Amazon Music I usually have to run it twice in order to get the screen to come up properly.  You can see it is trying to sync with the screen unsuccessfully.  I just got the 2nd Roku and will give it a try for a few days, however, in looking at it I will probably be returning it.

0 Kudos
Roku Guru

Re: Implementation of Dolby Vision and Dolby Atmos is poor

You didnt mention your firmware version:  Settings/System/About

Not sure what you mean when you say "both on a loop constantly testing screen and audio" - could you be more specific about what you are doing at the time and seeing/hearing?

Not sure how the Roku is "shutting off" your LG's display setting for that input, or what "the screen is not correct" means.

Make sure you have "HDMI ULTRA HD Deep Color" enabled for for that HDMI port in your LG:  Settings/General/HDMI ULTRA HD Deep Color=ON

For Dolby Vision, make sure you have "HDR Always on" disabled:  Settings/System/Advanced system settings/Advanced display settings/HDR always on=off

For Dolby Atmos, make sure you change "Auto detect" to "Auto passthrough":  Settings/Audio/HDMI=Auto passthrough

Sound settings/Volume Modes are completely broken for the 4800 in all builds of OS10 - you should report this directly to Roku: 

chat or email:  https://support.roku.com/contactus/contact-options  (choose setup/ultra/other/need more help?)

Amazon Music is a poorly coded app and has issues on other platforms too (e.g. For nearly a year it wouldnt open more than once on LG WebOS - had to be removed and reinstalled).

I just (re) installed it on my Rokus (4800) and as soon as it activated it went to a hung gray screen.  I had to go to Home and re-open it again.

As far as Atmos on Amazon Music goes, last I heard the Roku app doesnt even support HD (let alone UHD), and Atmos is only supported on Fire TV devices via Echo Studio.  There are reports that AirPlay from the Apple Amazon Music app to a Roku results in HD quality.


Regardless, you should contact Amazon for issues with the Amazon Music app.


0 Kudos