Features, settings & updates

Get troubleshooting tips to configure your Roku settings. The community forum has tips for screen mirroring, Guest Mode, software updates, audio, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to fix Google Assistant 'Unable to control your home device' message

Just bought a new Roku Ultra. I've set it all up and put it on the same wifi network as my google home. I've added it to the Google assistant and see the device in the app.

Whenever I say something like "hey google, launch Hulu on family room Roku", it responds with "sorry, something went wrong and I'm unable to control your home device."

I've made sure the OS is up to date and it's on v 10.5.0. I've removed the device from home assistant and unlinked Roku completely. Then rebooted the Roku. Then added it again. Still results in the same message.

I tried to switch the Google home and the Roku to a 2.4ghz wifi and still no joy.

Other than this, the Roku streams all the channels I've tried with no issues. The Google assistant is able to control all kinds of other devices in my home too. Just can't get the two of them to play nice together!

Can anyone help me figure this out?

Reel Rookie

Re: Google Assistant: "Unable to control your home device."

hola. tengo el mismo problema. leí que es debido a la ultima actualización de roku. es problema del software.

esperemos roku arregle este pronto.


si sabes.. escribes. 

0 Kudos