Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
bobcat1
Level 8

problems when switching inputs using a harmony remote

I have a harmony 665 remote connected to a Denon AVR with only 1 HDMI cable coming from my LG OLED TV(HDMI ARC). All my connections are HDMI (high speed 4k) and are connected to my AVR. The only connection from my tv to my AVR is the ARC. All other connections are to my AVR which include the 4k player. The problem is if I want to watch regular TV (through a spectrum DVR) the ROKU player which is always on comes up and I have to repeat the remote process to watch tv only. I have 6 devices connected to my AVR and all work well because the harmony can power down each device. Since there is no power off on roku ultra how can i avoid this other than disconnecting the player this function to work correctly?? Also if i program the sleep button into the harmony would this avoid the connection at start up?

0 Kudos
4 Replies
Tivoburkee
Level 20

Re: problems when switching inputs using a harmony remote

Turn off the 1-touch play in the roku settings:

 

settings> system>  control other devices(CEC)> uncheck the 1-touch play box

Read the paragraph next to it. 

Edmund
0 Kudos
bobcat1
Level 8

Re: problems when switching inputs using a harmony remote

The one touch is turned off-still same problem.Note that my TV requires Simplink (CEC) to be turned on when I am using HDMI cables. If I turn it off -I can work roku like my other devices BUT my TV will automatically switch to internal speakers-as mentioned the ONLY cable from my TV to my AVR is the HDMI (ARC) which sends audio and video to all my devices. Would you suggest that I use a OPTICAL cable for just ROKU? The problem is my TV wont let me use HDMI unless (simplink) CEC is turned on. When I power on my tv (from the watch tv button) it goes directly to my ROKU screen saver- if I push the TV button again it returns me to the TV. The solution is simple-find a way to power OFF ROKU while still being able to keep it connected to my system

0 Kudos
Tivoburkee
Level 20

Re: problems when switching inputs using a harmony remote

You have roku with optical? Do you have alexa in the house, you could get a alexa powered plug you connect between the roku power plug and the wall outlet? Even rename the plug roku. ALEXA turn off Roku. 

Edmund
0 Kudos
bobcat1
Level 8

Re: problems when switching inputs using a harmony remote

I have resolved the problem by connecting ROKU to my TV and changing the input source to another HDMI input skipping my AVR and having my harmony select that input. Although all my other inputs go through my (Denon) AVR the Harmony works quite well. It seems you cannot connect HDMI to my (LG) OLED tv without turning on (CEC) Simplink and since ROKU is always on changing the input to a TV input and chosing the TV audio from my AVR solved the issue. I only wish people with high end equipment would have a choice to turn off CEC from TV's and devices and to allow them full hookups to their AVR's and still use HDMI(ARC) for AUDIO ONLY