Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
SethNorton
Level 8

Way too bright!!

I own a TCL 6th generation 65" Roku TV. While watching shows the image brightness is still too bright even on Movie mode. My "TV brightness" is set to Darker and within the extra picture settings the backlight and contrast is on 0. 

The real issue is the home menu of the Roku TV. There are no image settings and its Blaring brightness really hurts to look at. What can I do? I've gone through every menu and setting and have not found anything. 

Labels (1)
12 Replies
RokuDanny-R
Roku Employee
Roku Employee

Re: Way too bright!!

@SethNorton

Thanks for the post.

Have you tried contacting TCL support yet to inquire further? I'd suggest starting there to see what options or suggestions they can provide. Each Roku TV manufacturer provides direct support for their products running the Roku OS. 

You can reach them here: https://support.tclusa.com/televisions or at 1-877-300-8837.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
GuitarMan
Level 10

Re: Way too bright!!

Unfortunately with these particular TVs you need to adjust the picture settings individually per input and per input format. 

Basically, when you're watching TV press the * button on the remote and go to Picture Settings.  There you'll find all the brightness, contrast, color temp, etc, settings.  But as soon as you change input source or format, you'll need to do it again.  There's no way to set those globally. 

BTW, if you have the 65R635, I have the same TV.   You can also try low power mode. 

0 Kudos
SethNorton
Level 8

Re: Way too bright!!

I understand that the picture setting changes with input source as I stated in my original statement. As I explained the issue is on the Roku TV home page i.e. where you select Netflix, Hulu, etc. The home menu has no picture settings to be adjusted hence why I have a problem.

0 Kudos
Mike-E
Level 9

Re: Way too bright!!

Sounds like it's in Showroom TORCH mode. You need to go back through the initial setup, and select "Home use" mode.

0 Kudos
GuitarMan
Level 10

Re: Way too bright!!

Maybe try changing to a different theme?  Unfortunately on my TV I only have 8 themes to choose from and they're not very good but some seem less bright than others.  Try maybe the nautical theme?

SethNorton
Level 8

Re: Way too bright!!

I know I set the TV up using home settings the first time. Just to be sure I formatted the TV and set up for Home use just as I did prior. Nothing has changed and the TV is still way too bright.

SethNorton
Level 8

Re: Way too bright!!

Snapchat-1641772601.jpg

 

Snapchat-1700570764.jpg

They are just screaming with brightness. It's such a pity I chose a TV with Roku TV as an OS when I'm a power user. Wish I could reload the OS to Android so I could actually change whatever settings I want to and im not blocked by their software limitations like brightness.

0 Kudos
GuitarMan
Level 10

Re: Way too bright!!

It's hard to tell from the pictures but just based on those pics it looks like the TV has a really bright hot spot in the middle of the screen that shouldn't be there.  Mine definitely doesn't look like that. 

Not sure how practical or possible it would be for you to exchange it but you may want to consider that.  You can also contact TCL directly to see if they have any ideas or suggestions. 

0 Kudos
SethNorton
Level 8

Re: Way too bright!!

I have a Galaxy S21 Ultra and not even the sensor on my phone can evenly light a photo properly due to the sheer brightness of the display while on the home menu. The TV doesn't look like that in person, the picture is amazing and evenly lit. Just wish there were more settings to change for the literal TV portion of the device and to not have it just only act as a roku.

0 Kudos