Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7

TV Locates Network but Won't Connect to Wireless Internet unless within 3ft of Router

I have an Insignia 55" Roku tv. I've been having an issue where it won't connect to the internet unless located within 3ft of my router. It finds the networks immediately, asks for my password, but then won't connect. Is this an issue with the wireless card, the tv model, or something else? I've tried resetting the tv, router, and internet connection and nothing has worked. What can I do to resolve this? My new home isn't laid out where I can have the tv that close to the router, and it seems absurd that it would need to be! It's currently located within 15-20 feet of the router and will not connect. I appreciate any support or information that may help.

-Roku model number: 7303X
-Insignia Model: NS-55DR620NA18
- Serial number: YN002D789772
-device ID: 8U9752789772
-software OS - unknown (nothing is labeled that way)

0 Kudos
4 Replies
Level 9

Re: TV Locates Network but Won't Connect to Wireless Internet unless within 3ft of Router

Is the tv connecting to the router through 2.4g frequency, or 5g? If it's the former, maybe there's a lot of neighbors using the same channel. You could go in your router and change it to use a different one. Usually routers have a scanning tool to show you what other devices are using a channel. 

If your router (and tv) is capable of 5g, I would setup the router to force the tv's mac addr to connect 5g. For example, my wireless/router will auto negotiate that (preferring 5g). But, one of my TCL tvs always connects 2.4g. So, I created a rule for that tv saying it must connect to 5g. 

2.4g is better for distance. 5g should be better for 20 feet to the router. Faster speed, less congestion/interference.

The tv should have home>settings>advanced>network reset. You might try that. Also system>power>system restart (like the customary "reboot your computer, see if that helps."). You could try those.

Yesterday I saw that there is a "secret screen" which is accessed through remote key sequence found with a google search. I looked at mine. There is a network screen which shows details that could be interesting. (I'd be careful not to do anything that changes any settings. It's just informative to see the details, perhaps.). My guess is you're using 2.4g and neighbors are interfering.

"[Roku CEO] Wood’s goal is to control video access to the world — to be the 'one box that rules them all.'" (Techcrunch, February 23, 2011). The latest software update removed any doubt who rules & controls my TV.
0 Kudos
Level 7

Re: TV Locates Network but Won't Connect to Wireless Internet unless within 3ft of Router

Thanks for the information! I wasn't able to see which frequency the tv was connecting to. I know it's capable of both but all it shows me is the network name, not the frequency speed. How do you force the 5G connection? Is that through the tv or the router? 

0 Kudos
Level 9

Re: TV Locates Network but Won't Connect to Wireless Internet unless within 3ft of Router

The router/wifi should show you the devices connected (and which band they're connected to. In my router, I can name the 2.4 SSID name differently than the 5g. So, when I look at the tv's settings, it tells me which name it's connected to. That's how I saw it was connecting to 2.4.), 

Most(?) routers let you control access using the connecting devices MAC address. It should show you the MAC address in the router, as one of the devices connected. You should be able to say you want it to connect to the 5g SSID. This feature might be part of an area in the router's menus where you can reserve an IP address for a device. That's how I do mine. I can name that device "living-room tv" and reserve 192.168.0.333 for it.[1] If I recall, that same feature in the router lets me say it can only connect to the 5g ssid. 

Spend some time poking around your router's admin menus.  If it's not intuitive, you could post the router brand/model. I could look at its user guide to see what it can do.

[1] My router is 192.169.0.xxx. Some are 192.169.1.xxx. Don't just copy/paste what I say. Adjust it to your router.

"[Roku CEO] Wood’s goal is to control video access to the world — to be the 'one box that rules them all.'" (Techcrunch, February 23, 2011). The latest software update removed any doubt who rules & controls my TV.
0 Kudos
Level 9

Re: TV Locates Network but Won't Connect to Wireless Internet unless within 3ft of Router

FYI: It's been a year since I set my router/wifi & tv to connect the way I described (forced to 5g). It's come back to me how I did that. My router (TP-Link AX-1500, which is inexpensive but powerful/fast. I've been very happy with it) has "smart connect" by default. That uses one SSID broadcasted name which all devices connect to. The router is supposed to negotiate 2.4g or 5g, somehow. One of my TCL tvs always connected to 2.4g. Not sure why. The only way I knew this was happening was to see it in the router/wifi's Nework Map>Client screen.

I turned off "smart connect" which requires giving 2.4g & 5g their own, unique SSID names. Choosing which wifi name to connect to is how I forced the tvs to connect to 5g. 

That sounds much simpler than what I described in my earlier post. My router lets me give names to devices connected, and then assign/reserve a specific IP address to them. I did that too. But, I don't believe that had anything to do with anything. Just being control freakish with my router/wifi. My earlier post mentioned mac addresses and access control. Routers do have the a feature to limit access to certain mac addresses. But, I didn't do that. The naming of devices, and assigning a specific IP address to them involves (or emphasizes) the mac address. That's what I was thinking of. But, it wasn't the typical access control that locks your wifi down to specific mac addresses. I didn't do that.

Some routers show a scan of devices using a 2.4 channel, which helps you pick a less congested channel. Mine doesn't (I'm not seeing it right now, anyway). There are wifi analyzer apps for smartphones that will show you that info. You might see a better channel to use for 2.4.

"[Roku CEO] Wood’s goal is to control video access to the world — to be the 'one box that rules them all.'" (Techcrunch, February 23, 2011). The latest software update removed any doubt who rules & controls my TV.
0 Kudos