Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
pocketlama
Level 7

Some videos on Vimeo give me an error

Jump to solution

I'm on a TCL Roku television. I can play some videos on Vimeo but others have a pop-up that says:

Error: Unable to play this video on Roku. Try playing it on a different device.

These videos I'm trying to open were bought and paid for previously. I've only watched them on the computer but I'd really like to get them on the television also!

1 Solution

Accepted Solutions
RokuDanny-R
Roku Employee
Roku Employee

Re: Some videos on Vimeo give me an error

Jump to solution

@pocketlama 

Thanks for the post.

Try removing the channel from the Roku home screen by navigating to the channel tile, pressing the * key on your remote and choosing 'Remove channel'. Then restart your device from Settings>System>System restart. Once your player starts up again, add the channel back once more. 

If the issue remains unresolved, I'd recommend reaching out to Vimeo directly to report the issue and request additional support. Many channels on the Roku platform are developed and maintained by the channel provider directly, and they'll be able to best assist. If other channels are working correctly, and you only experience this issue on the Vimeo channel (app), that is likely an indication that the issue lies within that particular channel. In these cases, the channel provider will need to investigate the issue in order to help resolve it.  

You can reach them here: https://vimeo.com/help/contact

Thanks,
Danny

Danny R.
Roku Forum Moderator

View solution in original post

0 Kudos
1 Reply
RokuDanny-R
Roku Employee
Roku Employee

Re: Some videos on Vimeo give me an error

Jump to solution

@pocketlama 

Thanks for the post.

Try removing the channel from the Roku home screen by navigating to the channel tile, pressing the * key on your remote and choosing 'Remove channel'. Then restart your device from Settings>System>System restart. Once your player starts up again, add the channel back once more. 

If the issue remains unresolved, I'd recommend reaching out to Vimeo directly to report the issue and request additional support. Many channels on the Roku platform are developed and maintained by the channel provider directly, and they'll be able to best assist. If other channels are working correctly, and you only experience this issue on the Vimeo channel (app), that is likely an indication that the issue lies within that particular channel. In these cases, the channel provider will need to investigate the issue in order to help resolve it.  

You can reach them here: https://vimeo.com/help/contact

Thanks,
Danny

Danny R.
Roku Forum Moderator

View solution in original post

0 Kudos