Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Screen Mirroring

Jump to solution

I have a 32 inch sanyo roku tv and I am trying to mirror my Samsung A10e smart phone. I've completed all instructions but no connection to tv.

The TV is listed in the Smart View menu but when asked to mirror screen it does not connect. TV screen mirroring mode is set to to (Always allow).

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Level 12

Re: Screen Mirroring

Jump to solution

Switch the Screen Mirroring Mode setting to "Prompt", then disable/enable Wifi on your phone and try connecting in SmartView again - you should then see a TV dialog asking "Always Allow/Allow/Block/ Always Block" - choose "Always Allow" (be patient, some devices can take up to 30 seconds to connect).

If you ever have trouble connecting after that, simply disabling/enabling Wifi on the mirroring device fixes connection problems 98% of the time.

Its best to leave the Mirroring Mode at "Prompt" for any additional devices you have, and for privacy/security reasons as well.

 

 

View solution in original post

24 Replies
Highlighted
Level 12

Re: Screen Mirroring

Jump to solution

Switch the Screen Mirroring Mode setting to "Prompt", then disable/enable Wifi on your phone and try connecting in SmartView again - you should then see a TV dialog asking "Always Allow/Allow/Block/ Always Block" - choose "Always Allow" (be patient, some devices can take up to 30 seconds to connect).

If you ever have trouble connecting after that, simply disabling/enabling Wifi on the mirroring device fixes connection problems 98% of the time.

Its best to leave the Mirroring Mode at "Prompt" for any additional devices you have, and for privacy/security reasons as well.

 

 

View solution in original post

Highlighted
Level 7

Re: Screen Mirroring

Jump to solution

Thank You. It worked.

0 Kudos
Highlighted
Level 7

Re: Screen Mirroring

Jump to solution

I also have the same problem with my Samsung A10e phone mirroring to the Roku Ultra.  I've tried all these tricks ( on/off wi-fi, smartview and every combination of ways to get it mirroring.  Still no luck.  Also three other people with same phone can't connect to Roku ultra in their places either!

Roku recognizes the phone with the tricks done and I "Allow" connection.  Then nothing!!  I already called Verizon and they say it's Roku, and roku says it's Verizon's Samsung A10e problem....ughh.  Want to throw both in the ocean.

Highlighted
Level 12

Re: Screen Mirroring

Jump to solution
@phelankrp wrote:

I also have the same problem with my Samsung A10e phone mirroring to the Roku Ultra.  I've tried all these tricks ( on/off wi-fi, smartview and every combination of ways to get it mirroring.  Still no luck.  Also three other people with same phone can't connect to Roku ultra in their places either!

Roku recognizes the phone with the tricks done and I "Allow" connection.  Then nothing!!  I already called Verizon and they say it's Roku, and roku says it's Verizon's Samsung A10e problem....ughh.  Want to throw both in the ocean.


You need to make sure you leave the Roku Screen mirroring setting at "Prompt" (Settings/System/Screen Mirroring Mode=Prompt)

When you make the mirroring request from the device (e.g. Samsung A10e using SmartView), and the Roku displays the on-screen dialog box with the choices "Always Allow/Allow/Block/Always Block" you need to make sure you select "Always Allow" (not "Allow").

(This is so the Roku stores that your device will always be allowed to connect and you wont be prompted by the Roku each and every time you connect, and thus also reduces connectivity problems/issues.)

If you dont see any devices listed in the the Screen Mirroring Devices list (Settings/System/Screen Mirroring Devices/Always Allowed=Samsung A10e/Your Device Name here), you haven't done it right (or you never connected after.)

Lastly, make sure your devices are not listed as "Always Blocked" (Settings/System/Screen mirroring devices/always blocked=none)

If you are using an always-powered Roku device (meaning you have it connected to the wall/outlet and its on all the time), reboot it first before connecting the first time (and if you have repeated problems connecting later).

 

0 Kudos
Highlighted
Level 7

Re: Screen Mirroring

Jump to solution

I should note, the Roku Ultra device has already allowed connection and does show Samsung A10e as one of the "Allowed Devices"! This took many attempts If I click on smart view on the phone to connect, is says connecting, then playing video, then the Roku device on the tv just stays on whatever was on before and doesn't play the running video from the phone.  

Basically, I have been connected, but nothing from the phone goes through, and smart view turns off on its own.  Three different A10e phones, and three different Roku Ultras and TVs, and none work.

0 Kudos
Highlighted
Level 7

Re: Screen Mirroring

Jump to solution

I tried the Re: screen mirroring instructions you gave me it's still showing

Always allowed devices

-none-

Every time I click on it it does absolutely nothing

To the right of that it says

The blocked devices list is empty

I've tried everything

Why won't it allow me to put my device in

I have a 55' TCL Roku smart TV

Please help me in going crazy trying to figure this out


@Gbrown872740 wrote:

I have a 32 inch sanyo roku tv and I am trying to mirror my Samsung A10e smart phone. I've completed all instructions but no connection to tv.

The TV is listed in the Smart View menu but when asked to mirror screen it does not connect. TV screen mirroring mode is set to to (Always allow).


 

Highlighted
Level 7

Re: Screen Mirroring

Jump to solution

I have tested everything but I was not successful I ask there is a simpler way to mirror the screen because even through windows I was not able to show that it will appear the screen connecting after leaving this is a defect?

0 Kudos
Highlighted
Level 7

Re: Screen Mirroring

Jump to solution

My Samsung A10e will not connect to any Roku tv. I have tried several different brands. There are 2 Roku televisions in my house.  A solution would be appreciated.  Nothing suggested here works.

Highlighted
Level 7

Re: Screen Mirroring

Jump to solution

Thank you so much!!! I would enjoy more of your replies to fix these technical problems. Simple and step-by-step.