Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Search instead for 
Did you mean: 
MelCoo331
Level 7

S-Series 55" Roku Infrared Receiver not working

Hi - I would love some advice since my TV is out of warranty by 4 months...anyhow, we were unable to use the remote and thought it was the batteries, replaced them, it didn't help. We purchased a new remote, still won't work. Went through some steps to reset the TV and now it is stuck on the page that asks which language and we can't get it past that in order to watch TV. I've also downloaded the app on my phone and it's asking for IP address. To get that I have to go to settings on the TV, but I can't get past the main set up screen to get the IP address!

I've seen in other forums that maybe it is the infrared receiver (I checked the IR lights on remote and it IS working). How can I determine if that is the issue? I appreciate any assistance!

Thanks!
Mel
0 Kudos
3 Replies
Community Manager
Community Manager

Re: S-Series 55" Roku Infrared Receiver not working

@MelCoo331

Thanks for the note. Your Roku TV manufacturer will be the best source to assist you here. Your Roku TV will require an active network connection in order to be controlled using the Roku Mobile app. Until your TV completes the setup process and is connected to a network, you won't be able to control it using the mobile app. 

I'd recommend asking your Roku TV manufacturer to confirm that the replacement remote you purchased is the correct model. You can also see the replacement remote we offer for Roku TVs here: https://www.roku.com/products/accessories/roku-tv

Your Roku TV manufacturer may be able to offer repair services or other options to help you get your TV back up and running as well. 

Thanks,
Tanner
Tanner D.
Roku Community Manager
0 Kudos
blade_005
Level 10

Re: S-Series 55" Roku Infrared Receiver not working

"MelCoo331" wrote:
Hi - I would love some advice since my TV is out of warranty by 4 months...anyhow, we were unable to use the remote and thought it was the batteries, replaced them, it didn't help. We purchased a new remote, still won't work. Went through some steps to reset the TV and now it is stuck on the page that asks which language and we can't get it past that in order to watch TV. I've also downloaded the app on my phone and it's asking for IP address. To get that I have to go to settings on the TV, but I can't get past the main set up screen to get the IP address!

I've seen in other forums that maybe it is the infrared receiver (I checked the IR lights on remote and it IS working). How can I determine if that is the issue? I appreciate any assistance!

Thanks!
Mel

Perhaps you have found a fix, but have you tried using the ON/OFF button and/or Keypad that is on the S-Series TV? My 55" P-Series has an UP/DOWN/LEFT/RIGHT/OK keypad on the back right side of the set for menu navigation. My 32" S-Series has an ON/OFF button and UP/DOWN buttons located underneath the TCL Logo. Not sure what might be available for your 55" S-Series, but worth investigating in case it can get you through the setup screen.
TCL-TV Roku 55P605 (4K HDR & DV) | VIZIO SmartCast SB3651‑E6 Soundbar
TCL-TV Roku 43S425 (4K HDR) | TCL-TV Roku 32S301 (720p)
0 Kudos
MelCoo331
Level 7

Re: S-Series 55" Roku Infrared Receiver not working

"blade_005" wrote:
"MelCoo331" wrote:
Hi - I would love some advice since my TV is out of warranty by 4 months...anyhow, we were unable to use the remote and thought it was the batteries, replaced them, it didn't help. We purchased a new remote, still won't work. Went through some steps to reset the TV and now it is stuck on the page that asks which language and we can't get it past that in order to watch TV. I've also downloaded the app on my phone and it's asking for IP address. To get that I have to go to settings on the TV, but I can't get past the main set up screen to get the IP address!

I've seen in other forums that maybe it is the infrared receiver (I checked the IR lights on remote and it IS working). How can I determine if that is the issue? I appreciate any assistance!

Thanks!
Mel

Perhaps you have found a fix, but have you tried using the ON/OFF button and/or Keypad that is on the S-Series TV? My 55" P-Series has an UP/DOWN/LEFT/RIGHT/OK keypad on the back right side of the set for menu navigation. My 32" S-Series has an ON/OFF button and UP/DOWN buttons located underneath the TCL Logo. Not sure what might be available for your 55" S-Series, but worth investigating in case it can get you through the setup screen.


Yes, it does have those buttons underneath the logo, but the up / down only adjusts the volume and the middle one just turns it on and off. Thanks for your suggestion! 
0 Kudos