Discussions

Premium audio. Made simple.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 8

Roku Wireless Speakers and Nintendo Switch (Pro Controller delay)

Jump to solution

I just received and setup a set of Roku Wireless speakers with my TCL Roku TV.  The setup was easy, the speakers are working fine and they sound great.  HOWEVER, when I now play my Nintendo Switch on my TV  - using the Wireless Pro Controller - there is a noticeable response-delay with the Pro controller.

I've confirmed that it is the speakers interfering with the Pro controller connectivity (by switching audio back to TV Speakers, testing, etc.).  Not really sure what to do.... i tried moving the Switch as far away from the speakers as possible but it doesn't help.

At this point, my only recourse would be to either:
- Change to TV Speakers when I want to play the Switch or
- Return the wireless speakers. Smiley Sad

Anyone else out there experiencing the same issue or have any thoughts?

Thanks,

Jeff

 

SOLVED:  Turning on Game Mode in the TV's Picture Settings seems to resolve the issue!  See here:  https://support.roku.com/article/360011799433-why-is-there-a-delay-with-video-game-play-when-i-conne...

0 Kudos
1 Solution

Accepted Solutions
Level 8

Re: Roku Wireless Speakers and Nintendo Switch (Pro Controller delay)

Jump to solution

SOLVED:  It looks like it was as simple as turning on Game Mode in the Picture Settings on the TV.  Found this solution:  https://support.roku.com/article/360011799433-why-is-there-a-delay-with-video-game-play-when-i-conne...

That seems to work!

View solution in original post

0 Kudos
6 Replies
Level 19

Re: Roku Wireless Speakers and Nintendo Switch (Pro Controller delay)

Jump to solution

Thanks for reaching out. Sorry to hear about the issue that you're running into!

I have a few more questions to help better understand your setup:

- What brand and model of wireless router are you using? 

- Are you using any wireless extenders or mesh networking access points? 

- Is your TV connected to a 2.4GHz or 5GHz wireless network?

With more information, we'll see what other recommendations we can make. Feel free to send me a private message with your Roku TV serial number and I'll follow up directly. 

 

Thanks,

Tanner

0 Kudos
Level 8

Re: Roku Wireless Speakers and Nintendo Switch (Pro Controller delay)

Jump to solution

I have Verizon Fios and am using the Google Wifi system for my mesh network.

I believe that Google Wifi uses BOTH the 2.4GHz and 5GHz bands for devices.  At least according to this:  https://support.google.com/wifi/answer/6293481?hl=en&ref_topic=6246470

I will send you my Roku TV serial number in a PM.

Thanks,

Jeff

0 Kudos
Level 8

Re: Roku Wireless Speakers and Nintendo Switch (Pro Controller delay)

Jump to solution

SOLVED:  It looks like it was as simple as turning on Game Mode in the Picture Settings on the TV.  Found this solution:  https://support.roku.com/article/360011799433-why-is-there-a-delay-with-video-game-play-when-i-conne...

That seems to work!

View solution in original post

0 Kudos
Level 19

Re: Roku Wireless Speakers and Nintendo Switch (Pro Controller delay)

Jump to solution

@jschuman 

Thanks for clarifying! I thought this was occurring with the setting enabled—glad to hear that isn't the case. 

I'm glad using that setting helped clear things up. Please keep us posted if you need anything further. 

 

Thanks,

Tanner

0 Kudos

Re: Roku Wireless Speakers and Nintendo Switch (Pro Controller delay)

Jump to solution

I was reading this thread in relation to Roku wireless speakers. I saw you asked about router and wireless network. Is there something I'm maybe missing regarding my connectivity issues (not being able to connect my speakers to my TCL Roku TV). I'm on a Google Mesh network like the sub here as well.

0 Kudos
Level 19

Re: Roku Wireless Speakers and Nintendo Switch (Pro Controller delay)

Jump to solution

@thedexteradams Thanks for reaching out. That sounds like a different issue from what you are experiencing.

I might recommend playing around with your network configuration, to see if making any changes impacts the behavior you are seeing. Things like disabling dual broadcast limiting your router to the 5GHz band only, ensuring your router isn't broadcasting on any DFS channels, and even trying to change the wireless broadcast channel on your router can help resolve these types of issues in some cases. 

If making a variety of adjustments as mentioned above isn't helping clear up the issue, feel free to send me a PM with more details about your specific setup, along with the serial number of your Roku TV from Settings>System>About, and I'll see what other suggestions we can make. 

 

Cheers,

Tanner 

 

0 Kudos