Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Roku TV won’t connect to WiFi but all other devices in house work!

I’m having the same issue. All devices EXCEPT my two RokuTVs have no trouble on 2.4ghz or 5ghz legs of the network. Roku TV 7103X TCL 55P605, Vernon 9.2.0 build 4504-30. 

8 Replies
Highlighted
Level 8

Re: Roku won’t connect to WiFi but all other devices in house work!

I am having the same issue. TCL roku loses wifi connection. Everything worked fine until a software update was installed a couple of days ago. Since the update, the wifi connection is dropped. It will eventually reconnect. I think that it is from a faulty software update.

0 Kudos
Highlighted
Level 16

Re: Roku won’t connect to WiFi but all other devices in house work!

@BGF1973 

Please stop panicking and posting so much.

Try the steps I outlined above.

Log other appliances out and reboot your Router.

See if the TCL sees the signal. You can also try turning your smart phone into a hotspot

and see if it sees that. Be patient but diligent. It will work out.

Roku Ultra ---Ethernet rules---

From now on if people dont upvote me and do as I say I will consider holding my breath and selling my Roku's.
Highlighted
Roku Employee
Roku Employee

Re: Roku TV won’t connect to WiFi but all other devices in house work!

@codemancmc @BGF1973 

Thanks for the post.

We recommend rebooting both your wireless router and your Roku device.

We would also recommend taking a look at the troubleshooting steps for network issues provided by our Support pages here: 
What should I do if I cannot connect to my home network or the internet?
Tips for improving the wireless connection to your Roku® streaming device

Keep us posted with what you find out. 


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Highlighted
Level 7

Re: Roku TV won’t connect to WiFi but all other devices in house work!

I am also have the same issue.  I have 2 Roku TV's and one of them connects just fine, along with my other devices.  But my other Roku TV will not connect.  It is finding my wifi network just fine, but when I put in my password and try and connect it doesn't do anything and I get the 0.14.05 error.  I have tried to reboot my router and the TV.  I even factory reset my tv and it still won't connect so I can't do anything else with it since it was factory reset. 

Highlighted
Level 7

Re: Roku TV won’t connect to WiFi but all other devices in house work!

Same thing happened with my roku tv. Wont connect now my screen is blue with a log on it. It wont allow me to update. Everytime there is am error. Maybe i messed it up more? I tried unpluging so many times. This TV is brand new it's not even a month old I've only used it maybe three times I've been remodeling it's been put away so now an update and everything is messing up

0 Kudos
Highlighted
Level 7

Re: Roku TV won’t connect to WiFi but all other devices in house work!

Hey Danny,

I shouldn't have to reboot my modem and wireless router every other day to keep my TV connected to my 5G. This is yet again something ROKU has screwed up.

0 Kudos
Highlighted
Level 7

Re: Roku TV Intermittent Network Connection Loss

My Insignia roku TV is doing the same thing almost every morning.

0 Kudos
Highlighted
Level 7

Re: Roku TV won’t connect to WiFi but all other devices in house work!

Update here:  The other night I logged into my account for my internet provider and did a reset on my modem and after that I was able to connect to the internet BUT, as soon as the TV went off and I turned it back on it would not reconnect.  I tried to do the same thing (reset my modem through my internet provider not by unplugging) and it did not work.  I have been able to connect to wifi on this TV VERY sporadically  and it takes multiple attempts and resetting network connection through the TV menu and unplugging both router and modem.  Sometimes it works and sometimes it doesnt.  Every time I AM able to get it connected to wifi, the next time I turn the TV back on I am in the same situation of trying to get it connected doing a series of different things (all of which are not consistent).  I HAVE to believe that this is a Roku issue (I noticed it once my software updates to 9.3), even though the error I am getting 014.50 indicates its an internet issue.

0 Kudos