Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Xojulia
Level 7

Roku TV error 009

I bought this tv almost a month ago and I still can’t use it. How do I speak to a love person to run through WiFi connection steps I’ve tried everything and keep getting the error 009 and my internet works perfectly fine. 

0 Kudos
3 Replies
atc98092
Community Streaming Expert

Re: Roku TV error 009

Roku does not provide support for the TVs, as they are not the manufacturer. They only provide the operating system. I've seen that error message posted here before, but I can't recall what the issue might have been. 

If your WiFi password has special characters, (such as !, $, & or similar) that might be the problem. Roku devices will only connect if the password is just letters (upper and/or lower case is fine) and numbers.

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
RokuDanny-R
Roku Employee
Roku Employee

Re: Roku TV error 009

@Xojulia 

Thanks for the post.

For troubleshooting steps regarding that error code, visit our Support page here: What should I do if I cannot connect to my home network or the internet?

Please keep us posted what you find out.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
mnvw
Level 7

Re: Roku TV error 009

Hi, I had a similar issue where my once connected TCL Roku TV started saying it wasn’t connected but still actually was. The error messages were annoying enough to reset the network connection and also a factory reset and then I was unable to connect to my cable Internet at all. It would however connect to my phone hotspot instantly. When trying to connect to the main home Wifi it would give me the first green check mark, but fail at the second Internet step. After many support calls with Google WiFi, TCL and my ISP... no one could figure it out. Today, I tried the test connection option in the network menu and after 5-10 seconds it said it was connected. So I had my answer — the WiFi connection process does not allow much if any latency in the network, but the connection test allowed enough time to connect. I called my ISP and they disconnected and reprovisioned my modem and the latency was resolved and the TV was able to connect. I hope this saves someone the frustrating journey I was on the past 2 weeks.