Is your Roku TV not working? Join our online community forum to find help with common Roku TV issues, get troubleshooting tips, and share your experiences.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Roku TV - TCL 43S303 (5143x) - 5GHz connection disappears

Yesterday, I turned on the TV and received a persistent "Updating software" dialog box. The TV was not connected to the internet, so I exited the update and went to the Network screen to set my connection, but the SSID for my usual 5GHz option didn't appear upon scan. Thinking that the problem might be connected to the update, I successfully updated the software via mobile hotspot. However, the 5GHz connection was still missing from the scan list. (I also tried connecting as a private network, which didn't work either). (ETA: The scan list does show other local networks.)

My usual 5GHz connection is through an extender that uses the same 5GHz channel as the router. I have tried three different channels > 149 to no avail, resetting the router, extender, and TV each time. I have also checked congestion on those channels (no competition). On most recent attempt, I noticed that the 5GHz channel appeared in my list immediately after reset, but disappeared before I could select it. Why would this be?

For reference, the TV is running software version 11.0.0, version 4193-08, but I don't know exactly when it was updated. I can access the internet via 2.4GHz connection to the same extender, but the 5GHz connection worked a couple of days ago and I'm curious as to why it doesn't anymore.

0 Kudos
Community Streaming Expert

Re: Roku TV - TCL 43S303 (5143x) - 5GHz connection disappears

I don't have an answer, but can you try a channel < 50?

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.