Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jeffrok
Level 13

Re: Roku TV - No Option/Setting to Use Optical Audio?

Jump to solution
The Roku TV has an optical output, not input. I believe all Roku TV's are like this. I use my TCL Roku TV outputting via optical to a sound bar.
Yeah, I got some Rokus.
https://youtu.be/d1CSEeqWl10
0 Kudos
gadrago
Level 9

Re: Roku TV - No Option/Setting to Use Optical Audio?

Jump to solution
Kinda tongue in cheek, but there's nothing much in optical audio instructions because there's nothing much to do to make it work.  In TCL settings, whether TV speakers are set to on or off makes no difference since TV is always outputting a signal from its optical output port.  Things to recheck are optical cable connections and receiver settings.  If the optical cable is connected correctly at both ends and the correct receiver input is selected, it usually just works.  Optical cables are keyed so that they are only inserted correctly in one of the four 90-degree directions of rotation,  even though it seems like it is connected correctly at  the TV end if you can see light coming through at the unconnected receiver end of the optical cable.  But it's worth a recheck at both ends if you have never used an optical cable before.

Your receiver has two optical inputs.  If you have not changed the default input assignments, they are DTV/CBL and CD.  Assuming you have connected the optical cable to DTV/CBL and selected that as the receiver input, did you also try connecting the optical cable to the CD input and selecting that receiver input to see if one of the receiver optical inputs is defective?  Only other thing I see in your receiver is to check that the Audio Select setting for the DTV/CBL and CD inputs is set to AUTO not ANALOG. If set to ANALOG instead of AUTO you wouldn't get sound from a digital source.  Also I suppose you could check that the DTV/CBL and CD inputs have not had any receiver audio input reassignments from the defaults (wherein the two optical input ports are mapped to those two inputs), although I don't see why that would have occurred without your knowledge.  If the optical ports had been remapped from their default DTV/CBL or CD input assignments, that would explain why you are not getting any sound when selecting those inputs.

I have Panasonic and TCL televisions, and have connected two different Yamaha and two different Sony receivers to them via optical connections over the years with no problems, before HDMI/ARC came along.
0 Kudos
Atreties
Level 8

Re: Roku TV - No Option/Setting to Use Optical Audio?

Jump to solution
gadrago, thank you for taking the time for the detailed reply, and even with the research on my receiver, to boot!

I will try everything again when I get home, but yes, I did connect it to the DTV/CBL port, and selected that as the input. I also tried the CD input with the CD port. Also tried the ports with the opposite inputs. Nothing produced any sound whatsoever. Made sure to have the volume up quite loud, with a video playing the entire time to make sure i'd detect any sound. 

Also, yes, the audio select setting is on Auto, not analog.

My best guess of the cause at this point is in the cable, so I've ordered a new one. I don't see how it could be the cable given that I can see the red light on the opposite end of the cable once one end is plugged into the TV output, but I figure it's worth trying. Maybe it's damaged instead of fully broken... But from what I've read, that would lead to messed up/intermittent audio, not no audio at all.
0 Kudos
twiceover
Level 13

Re: Roku TV - No Option/Setting to Use Optical Audio?

Jump to solution
"Atreties" wrote:
gadrago, thank you for taking the time for the detailed reply, and even with the research on my receiver, to boot!

I will try everything again when I get home, but yes, I did connect it to the DTV/CBL port, and selected that as the input. I also tried the CD input with the CD port. Also tried the ports with the opposite inputs. Nothing produced any sound whatsoever. Made sure to have the volume up quite loud, with a video playing the entire time to make sure i'd detect any sound. 

Also, yes, the audio select setting is on Auto, not analog.

My best guess of the cause at this point is in the cable, so I've ordered a new one. I don't see how it could be the cable given that I can see the red light on the opposite end of the cable once one end is plugged into the TV output, but I figure it's worth trying. Maybe it's damaged instead of fully broken... But from what I've read, that would lead to messed up/intermittent audio, not no audio at all.

Note that Auto Detect does not work with Optical.  At least that is what the Roku Engineers told me when I first used optical.  You need to set the audio to what your receiver can decode, more than likely stereo or DD/DD DTS.  I do not believe DD+ works over optical on a Roku TV.  You would hear nothing if you send DD+ over optical.
0 Kudos
apodtele
Level 10

Re: Roku TV - No Option/Setting to Use Optical Audio?

Jump to solution
I found Yamaha RX-V361 manual. Please make sure you follow pages 58 and 29.
0 Kudos
Atreties
Level 8

Re: Roku TV - No Option/Setting to Use Optical Audio?

Jump to solution
Issue resolved.

Problem was in the optical cable. Even though i could see light thru the cable, it must have been damaged somehow. Damaged cables usually emit intermittent signal, but mine gave nothing at all. If you have a similar situation and everything seems like it should work, try replacing the cable.

Re: Roku TV - No Option/Setting to Use Optical Audio?

Jump to solution

Solution is non-solution for me. Optical cable works perfectly on TV. When input is switched to Roku digital output stops. This is an older JVC TV.

I have a new Samsung where the optical works perfectly with the Roku.

So do I just give up and get rid of Roku and go to Amazon plugin?

0 Kudos
bhoyo68
Level 8

Re: Roku TV - No Option/Setting to Use Optical Audio?

Jump to solution

Hi,

I have my TCL 55r615 hooked up with a optical cable to a 2015 Marantz receiver.

Try setting SPDIF/ARC (Optical) input to 2.0 instead of auto or 1.4....

Works for me, hope this helps.

 

Paddy

fspataro
Level 7

Re: Roku TV - No Option/Setting to Use Optical Audio?

Jump to solution

Hey, I'm trying to set up my surround sound now, I know this thread is a year old but if @Atreties sees this, what was your audio output set to? PCM, DD or DD+, etc. and were your tv speakers turned off. thanks!

 

0 Kudos
MebaneMike
Level 8

Re: Roku TV - No Option/Setting to Use Optical Audio?

Jump to solution

I have sound on optical on Hulu channel but not watching Roku Channel?

0 Kudos