Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
scotchtape
Level 8

Roku TV Light under TCL logo at bottom of screen won't stop blinking

Every 2 seconds it blinks twice. How do I make it stop?

40 REPLIES 40\
scotchtape
Level 8

Re: Light under TCL logo at bottom of screen won't stop blinking

Finally figured out it was trying to find a network connection.  Only solution I could find was to do a factory reset.  There is no permanent internet connection available for the TV.  Is there some other way to disable searching for a connection?

andyross
Level 16

Re: Light under TCL logo at bottom of screen won't stop blinking

Do you ever connect it to Internet? If not, is there an option to disable Internet usage or disable WiFi?

0 Kudos
scotchtape
Level 8

Re: Light under TCL logo at bottom of screen won't stop blinking

I can only connect temporarily, just one ethernet cable, and no wifi.  I connected, made an account, and downloaded updates, hoping it would help solve an issue I'm having with brightness controls.    I  couldn't find any way to disable the internet connection.  It just seems to expect it forever once it finds it.

0 Kudos
andyross
Level 16

Re: Light under TCL logo at bottom of screen won't stop blinking

If you router/gateway only has one Ethernet port, you can get an Ethernet switch to let you hook up multiple devices. They are relatively cheap:

https://www.amazon.com/Aumox-Ethernet-Unmanaged-Optimization-Play%EF%BC%88AM-SG205%EF%BC%89/dp/B07QL...

0 Kudos
scotchtape
Level 8

Re: Light under TCL logo at bottom of screen won't stop blinking

I'm not interested in that, I have no need for internet on the TV except when checking for updates.  I don't use it for much beyond a computer monitor.  I just want to  turn off it searching for an internet connection when one isn't present

0 Kudos
blade_005
Level 14

Re: Light under TCL logo at bottom of screen won't stop blinking


@scotchtape wrote:

I'm not interested in that, I have no need for internet on the TV except when checking for updates.  I don't use it for much beyond a computer monitor.  I just want to  turn off it searching for an internet connection when one isn't present


There is an option to set the TV up without Roku features as a non-smart TV / Monitor. See link below.

 

Turning Off the Roku Features of Your TCL Smart TV 

 

What I don't know is if setting it up this way will disable network functionality and prevent the blinking light that is trying to establish a network connection. I would think it would since you are setting it up as a non-smart TV.

 

 

TCL Roku-TV 55P605 (4K/HDR/DV) | VIZIO SB36512‑F6 ATMOS Soundbar | Fire TV Stick 4K
TCL Roku-TV 43S425 (4K HDR) | Fire TV Stick 4K
TCL Roku-TV 32S301 (720p) | Fire TV Stick 4K
YABER Y31 1080p LED Projector | ONN 5.1.2 Dolby ATMOS Soundbar | Fire TV Stick 4K
scotchtape
Level 8

Re: Light under TCL logo at bottom of screen won't stop blinking

Thanks.   Ah well, that is ultimately what I did.  A factory reset and not setting up a connection to begin with does work.   I guess I'm just not understanding why there isn't a way to manually shut off the connection in the event you do set it up temporarily.  It seems weird to have to do a factory reset just to turn off the connection.

JasonDean
Level 7

Re: Light under TCL logo at bottom of screen won't stop blinking

I agree there should be a setting you can change. With all this junk going on my kids schools just went to online classes. Couple that with a recent move and my internet provider not wanting to come and set up internet at my new house, all I have to connect to the streaming services is my cell phone's mobile hotspot, which I don't have on all the time to preserve data. So if I am watching over the air tv, my Roku Sharp TV is constantly blinking. Seriously Roku, make a setting to turn that insipid light off...

Rani-k
Level 7

Re: Light under TCL logo at bottom of screen won't stop blinking

Thank you all for your help. Factory resetting and not setting up a connection worked!

Background info: I noticed my internet got worse when I connected it to the TV. Tried removing the connection and started seeing the same very annoying light flickering behavior. The flickering only happened when I was on HDMI for some reason, not when I am at the TV's home page.

Agree that there needs to be an option for this. I don't see why it would constantly try to connect when I've deliberately not connted to wifi.

Come to think of it, even with a wifi connection on why would it constantly work to maintain that connection when I am using HDMI?