Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
roquoonewbie
Level 9

Re: Private Listening Mode on Roku TV

Yes it is really frustrating.  It is not a latency issue, because the workaround mentioned above (attaching a BT transmitter/reciever to the headphone jack on the TV) works with minimal to no latency.  So it is totally possible.  All the TV manufacturer would have to do is embed a BT transmitter/receiver in the TV...at worst. No real explanation why Roku can't enable private listening for HDMI connected content.  
0 Kudos
beq
Level 9

Re: Private Listening Mode on Roku TV

Hmm I agree it would be convenient.

But I can understand the audio lag with mobile app private listening, which routes audio via your infrastructure Wi-Fi (ie. your router somewhere in the house) before traversing back to reach your phone.  And using Bluetooth headphones with your phone adds yet a bit more lag on top of that.  When I switch to mobile private listening (using BT AirPods) in the middle of a video, Roku purposely pauses it for 1-2 secs until the re-routed audio is ready to go.  Afterward any button presses (pause, replay, etc) takes 1-2 secs to register because of the delayed playback.  Finally when turning off mobile private listening, the video stutters and skips ahead 1-2 secs (to return to "realtime").

In contrast, remote headphone jack private listening sends audio via the Wi-Fi Direct connection, from the Roku straight to the remote.  Switching the remote headphone audio in and out during playback seems to take a split second without the Roku interrupting the video.

So if the Roku TV can't delay/buffer the video signal on HDMI inputs (?), enabling mobile private listening may likely lead to a noticeable lip syncing issue. Perhaps that's why Roku disables it in the app for HDMI sources?
0 Kudos
beq
Level 9

Re: Private Listening Mode on Roku TV

"roquoonewbie" wrote:
It is not a latency issue, because the workaround mentioned above (attaching a BT transmitter/reciever to the headphone jack on the TV) works with minimal to no latency.

Just to clarify, pairing BT headphones to a BT transmitter adapter that's plugged in to the TV headphone jack, means the audio is wirelessly sent direct to the headphones over the short Bluetooth link.

Similarly, using wired headphones with the Roku remote jack, means the audio is wirelessly sent from Roku direct to the remote via Wi-Fi Direct.

Whereas with Roku mobile app private listening, the BT headphones are paired to the mobile phone, which in turn is joined to the Wi-Fi LAN that the Roku is also joined to (as different IP clients managed by the router somewhere in the house). So the audio must be sent via Wi-Fi from the Roku to the router (barring any Wi-Fi extender/repeater), then to the mobile. And then from the mobile to the headphones via BT.


Now, since Roku does enable remote jack private listening to work on Roku TV HDMI inputs, we could try plugging in a BT transmitter to the remote headphone jack, though that would be one more thing to power up. And it would involve wirelessly sending the audio via both Wi-Fi Direct and then Bluetooth, but at least we'd skip the wireless roundtrip via the infrastructure Wi-Fi (the router and any extender/repeater). I'm curious how much latency this compares?
0 Kudos
Highlighted
roquoonewbie
Level 9

Re: Private Listening Mode on Roku TV

Now, since Roku does enable remote jack private listening to work on Roku TV HDMI inputs, we could try plugging in a BT transmitter to the remote headphone jack, though that would be one more thing to power up. And it would involve wirelessly sending the audio via both Wi-Fi Direct and then Bluetooth, but at least we'd skip the wireless roundtrip via the infrastructure Wi-Fi (the router and any extender/repeater). I'm curious how much latency this compares?

I'm not sure what your question is or how you would want me to answer it.  I have no Roku remote with jack.
0 Kudos
Bineet
Level 7

Re: Private Listening Mode on Roku TV

"roquoonewbie" wrote:
Now, since Roku does enable remote jack private listening to work on Roku TV HDMI inputs, we could try plugging in a BT transmitter to the remote headphone jack, though that would be one more thing to power up. And it would involve wirelessly sending the audio via both Wi-Fi Direct and then Bluetooth, but at least we'd skip the wireless roundtrip via the infrastructure Wi-Fi (the router and any extender/repeater). I'm curious how much latency this compares?

I'm not sure what your question is or how you would want me to answer it.  I have no Roku remote with jack.


Hi did u find a solution to this?
0 Kudos
roquoonewbie
Level 9

Re: Private Listening Mode on Roku TV

Roku has not provided a solution, after all this time.
0 Kudos
KJSS
Level 7

Re: Private Listening Mode on Roku TV

I have the same problem.  I got a TCL TV 43" from costco for 220 dollars.  Its a great cheap tv.  Bright colors.  But private listening does not work.  I know its only select models.  But in the ROKU app on my Motorola Z3 PLAY when I say change device.  ( I also have a 4k stick connected to another tv) When I change device it says (43" TCL Roku TV).  So it recognizes the TV.  And the arrows and home button work.  And even the microphone which the remote that came with the tv does not have works.  But when I tap the earphones it says (Private Listening is not available for this input).  I understand its not for HDMIs.  But I am not on any input.  I am on input 0.  I am on the main ROKU os on the TV.  I am not on any of the 3 inputs on the TV.  I mean it does not even work on the ROKU portion.  Should at least do that.  Why even connect to the TV from the APP if it does not support private listening.  It should not connect at all in the first place.  If it connects and controls the TV then private listening. should wotk also.

Edit: never mid it started working all of a sudden.  No changes not sure why.  Before even netflix was not working on the ROKU side.  Now it works.  Input 3 a slash through the earphone icon.  Then hit home button and it disappears.  Then switch to antenna and its back to the red line through the earphones icon.  Back to home and the line is gone.  How odd 5 minutes ago it was not.  The TV went to sleep and after I pressed the power button on the physical remote and turned it back on it works now.  How odd.  But after turning the tv off and on it works again how odd. 

Also I changed input 3 to be the default when the TV turns on.

Plus is even says when I tap the earphone icon its only for streaming and digital antenna only.  But on antenna input it does not work how odd.  And now after leaving antenna input on for 5 minutes and then going back to home the line in the earphone jack stays and does not disappear.

I changed the default to home screen and same thing.  If I switch to AV, Or HDMI 1, 2, or 3 and then back to home the red line goes away.  But if I switch to antenna and then back to home the red line stays on.  Then I turn the TV off and then on and the red line goes away.  Or switch to HDMI 3 and then back to home before turning off the TV and the red line goes away so no need to turn off the tv.

How odd.
0 Kudos
Slumpbrick
Level 7

Re: Private Listening Mode on Roku TV

I agree, an explanation from Roku would be very helpful.  When you do a search on this topic all you get is rosy explanation that don’t address the issue.  

0 Kudos