Discussions

More than a smart TV—a better TV. Learn more about using your Roku TV, locate help resources, and share your experience.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Musoka
Level 10

Re: [OS 10.5] Roku TV experiencing loading channel issues

I've been tracking my issues through a number of threads here (since it seems they aren't actually trying to work out real data points). Background is in IT and I'm tired of this. Indeed, something about dns is amuck. Other users and I narrowed down that their primary dns was a failed address set ages ago, secondary dns isn't being utilized. As for myself and others, a pihole is INDEED in play. And this started after 10.5. My paramount+, Disney+, and the TV guide itself all no longer work. We've posted real world examples and data on other threads but I honestly suspect this is above these support people's heads (not their fault, that's customer service these days, they don't pay for people with real technical background). They have not responded or contributed anything to the conversation with regards to their networking protocols being at fault for numerous issues. 

I refuse to alter my network setup because this company seems to want to mess with pihole or dns control in general. So I've ordered a chromecast with Google TV... Enough is enough. But I want my tv all working properly before I take it offline permanently. After all these problems and others with the firmware, I no longer trust them not to brick the TV. It's been a fun 5 years or so roku but this was just too much for me. 

PMattABQ
Level 8

Re: [OS 10.5] Roku TV experiencing loading channel issues

I disconnected my Roku device and power cycled it and my connectivity issue was resolved, but the play of Paramount+ channels is often halted during attempts to load commercials, with the error message that Roku is unable to play the episode or that it is unavailable. That seems to be a choke point for connectivity. As I've reported elsewhere, he Fish Tank screensaver that used to appear when I made the Roku selection from my universal remote no longer shows up. After showing the "no connection found" screen, I have to hit Home on the Roku remote and the Home Screen appears. Permitting the Home screen to time out does produce the Fish Tank.

Folks, it's Christmas time and it's really hard to consider gifting a Roku device with these issues unresolved after a month or so. Not your best marketing strategy, unless you thought it would push us to upgrade to a newer model... until it gets a software upgrade and stops working as well. Seems like you didn't learn from the HP inkjet printer debacle.

PMattABQ
Level 8

Re: [OS 10.5] Roku TV experiencing loading channel issues

@Musoka I can relate. One of my Roku Ultras got bricked when I didn't register it in a timely manner, never mind that I already HAVE a Roku Ultra and it was for another room in the house. I had to get a replacement unit sent and sent back the bricked unit. Annoying.

Wanted to warn you about Chromecast issues. I hope they've made changes, but after about 6 months, mine started trying to impersonate an ISP and started hijacking all of my WiFi connections. It required a factory reset to start behaving itself again, but that lasted for less and less time and I finally switched to Firestick for a time.

0 Kudos
Sir_Launcelot
Level 8

Re: [OS 10.5] Roku TV experiencing loading channel issues

@Musoka I mentioned in this thread what the issue I saw was, and no one from Roku reached out.  Some people blame Comcast, but they implemented the network protocols correctly.  The various channel providers also seem to be correctly implementing DNS.  The issue is with Roku not implementing the client side dns correctly.  I would ask everyone who has an issue who their internet provider is and if their computer or other devices are using IPv6 from thei provider?

0 Kudos
MichaelS1
Level 9

Re: [OS 10.5] Roku TV experiencing loading channel issues

We need this rolled back and fixed. Release the 10.0 file online and allow us to load it via USB, or allow us to roll back the update like some people can. This isn't a ridiculous request. 

At this point if my TV ever starts working with HDMI properly again I'm disconnecting it from the internet and buying a streaming stick fir streaming apps.

rollmebacknow
Level 8

Re: [OS 10.5] Roku TV experiencing loading channel issues

I will never buy another Roku TV ever again. 10.5 installed and the * menus SUCK. I happened to be using the TV when it automatically downgraded itself... funniest facepalm I've ever seen in tech Roku, grats you duncehats. 

Not sure how long it's been since but after a few days it automatically upgraded to 10.5 again. Again, the menus SUCK but moreover the lag from my PC miracast screen mirroring is INSANE. It's literally stop, go, stop, go, repeat. A few seconds every time it freezes until it buffers and syncs back up. Endlessly. 

THIS WAS NOT A PROBLEM UNTIL 10.5. TCL 55S403. I've got to find a way to factory reset the unit and get the channels back but block the update. Not sure that could be accomplished even with PiHole or other traffic filtering methods. 

This is **bleep**. You've lost a customer. I will advise against using Roku with everyone I know. I'm livid. 

0 Kudos
Mathmom
Level 8

Re: [OS 10.5] Roku TV experiencing loading channel issues

I don't know if this will help others but ours seems to be fixed for now without rolling back to 10.0. Here are the 2 things together that seemed to have fixed it for us (our issue was being able to view titles but unable to select and actually stream without it just hanging out doing nothing. Our signal strength is excellent and I am able to stream fine from apps on my DVD player or Comcast flex box and it all started when. 10.5 upgrade come.

  • Network connection reset - (Press the home button on the Roku remote, select Settings>>System>>Advance settings system>>Network connection reset

  • system restart from within the TV which : (via settings -> power -> system restart)

I am in no way a techy, but these 2 steps resolved for us (for now). I hope this helps some of you. We have a TCL Roku TV 4201-88 build 10.5 OS. 

0 Kudos
jcubed59
Level 8

Re: [OS 10.5] Roku TV experiencing loading channel issues

Over the weekend an update was pushed to me, but it was nondescript (refer to message dialogue below). I Installed the update and the device was restarted, however, my streaming issues persist. Note the absence of a version build numbers.

Update available

The system will perform any additional updates if needed.

This may take a few minutes. You will not be able to use your device until the updates are complete.

Once the updates are installed, the affected devices will restart automatically.

Tags (1)
0 Kudos
Gary-94080
Level 12

Re: [OS 10.5] Roku TV experiencing loading channel issues

I have seen updates like this many times.  they come through and are not identified.  instead of saying what program is being updated it says something like "turbo charging your experience".  when these updates come through the version and build numbers do not change.  so what has changed is known only to the Roku techs.

0 Kudos
spammy
Level 7

Received the 10.5 update again and stuff broke again....

I have 5 Roku devices and they all have a new issue after the update today 12/10/2021... no video on some apps... yay! 3 TCL Roku TV's, 1 Roku LE, and 1 Roku steaming stick. I receive Roku hdcp 1.4 errors on all of them unless I change my setting on the Roku to correspond with the exact resolution that my video will be streaming in. So I have observed this in Netflix and Plex... and it's pretty stupid.

0 Kudos