Is your Roku TV not working? Join our online community forum to find help with common Roku TV issues, get troubleshooting tips, and share your experiences.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Reel Rookie

Not connecting to my Roku tv

I see the Roku remote app and have a Roku TV. Everything was working fine until today. Turned on tv and opened remote app. It said I was connected to the correct device but when I tried to go to the guide it said I needed to connect to a device. In purple it said wake this device referring to my tv. I tried to do that and it just kept searching for devices and just timed out without connecting. Tried several times. I have strong fast internet and did not say I wanted connected to Wi-Fi. I disconnected the Wi-Fi and turned back on same thing. I went into my Roku account and it says I have no devices linked. Also when I open the remote app it used to say my name now it say happy streaming and no nothing works. I changed my account password because that seemed unusual. Any thoughts or suggestions on what the issue may be?

0 Kudos
Retired Moderator

Re: Not connecting to my Roku tv

Hi @Dandilion

Welcome to the Roku Community!

I'm sorry to hear about the trouble you're experiencing with the Roku remote app and your Roku TV. Here are some troubleshooting steps you can try:

  • Ensure Wi-Fi connectivity: Even though you mentioned having a strong and fast internet connection, it's still worth double-checking that your Roku TV is connected to the Wi-Fi network. Go to the settings on your Roku TV and navigate to the Network section to confirm the connection status.
  • Restart your Roku TV: A simple restart can often resolve connectivity issues. We recommend doing this from the Settings menu by navigating to 👉 Settings > System > System restart > Restart.
  • Restart your mobile device: Similarly, try restarting the device you're using to run the Roku remote app. Sometimes, issues with the app can be resolved by closing it completely and relaunching it after a fresh start.
  • Check for app updates: Ensure that you have the latest version of the Roku remote app installed on your mobile device. Visit your device's app store (e.g., Google Play Store or Apple App Store) and check for any available updates for the Roku app. If an update is available, install it and try connecting again.
  • Reinstall the Roku remote app: If restarting your device and updating the app didn't work, try uninstalling the Roku remote app and reinstalling it. This process can help resolve any potential issues with the app's installation or configuration.
  • Verify network settings: Check the network settings on your Roku TV to ensure that it's connected to the correct Wi-Fi network. If you have multiple networks available, make sure you're connecting to the one you intend to use with your Roku TV.
  • Reset network settings on Roku TV: If all else fails, you can try resetting the network settings on your Roku TV. Go to the settings menu, navigate to Network, and look for an option to reset network settings. This action will remove all saved Wi-Fi networks, and you'll need to set up the Wi-Fi connection again.

We hope it helps!

Warm regards.

0 Kudos
Reel Rookie

Re: Not connecting to my Roku tv

Hi and thank you for your reply and suggestions. I verified that my tv and phone are connected to the internet my home network. I’ve restarted the tv and my phone. I’m unable to get to the settings on my tv. I don’t have the tv remote. I usually control my tv with my Xfinity remote or the Roku remote app on my phone. On the Xfinity remote I’m only able to go to inputs. Nothing else works with that remote either maybe because my service I suspended? I do still have internet though b cause of the affordable connectivity program.Is it possible that someone else is connected to my Roku tv or Roku account. It says that I’m connected to my Roku tv but remote doesn’t work it just continues to search for devices when I try to wake the tv like it suggests.  But at the same time it says it is connected? Please help. In the meantime I will try to delete the Roku remote app and reinstall however I have an iPhone and it’s impossible to completely delete an app. It always saves to my iCloud and just reinstalls the app again with no resolution. I’m will try again 

0 Kudos